If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

JS error in viewZoomOverlay.js at startup

VERIFIED FIXED in mozilla0.9.7

Status

SeaMonkey
UI Design
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: Simon Fraser, Assigned: jag (Peter Annema))

Tracking

Trunk
mozilla0.9.7
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I now get this JS error on every startup:

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "this.bundle has no properties" {file: 
"chrome://communicator/content/viewZoomOverlay.js" line: 49}]' when calling 
method: [nsIDOMEventListener::handleEvent]"  nsresult: "0x80570021 
(NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "<unknown>"  data: yes]
************************************************************
(Assignee)

Comment 1

16 years ago
Hmm, yeah. It looks like the binding isn't quite ready yet when we use it there
(though it is on other platforms, seems to be some timing thing).

I think I can get rid of the dependency on having the bindings load in some
specific order.
Assignee: blakeross → jaggernaut

Comment 2

16 years ago
(just for the record - you seem to know what the problem is...)
The assert appeared after my checkin for bug 39117 and apparently it was not 
fixed by pink's checkin for bug 97549.
(Assignee)

Comment 3

16 years ago
Yes. Basically it was a latent problem waiting to surface. Thanks to pleasant
timing on Windows and Linux, this code wasn't called until the stringbundle
binding in question had already been bound to. On the Mac, which until recently
(your checkin) didn't use this code, the timing is different and this warning
shows up. It's code that can actually just be removed if I remember this
correctly, so ...
(Assignee)

Comment 4

16 years ago
-> 0.9.6
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 5

16 years ago
-> 0.9.7
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Reporter)

Comment 6

16 years ago
Current builds are giving me 3 (three) JS errors on startup, possibly unrelated 
to this one.
(Assignee)

Comment 7

16 years ago
Scratch all that. hiddenWindow.xul loads this code without having a place for
the stringbundle to overlay on. This causes the error, which causes the rest of
the init code to not run, which in turn causes the Text Zoom menu item to remain
hidden. I guess what we'd want is for the menu item to be there, but disabled.

Patch coming up.
(Assignee)

Comment 8

16 years ago
Created attachment 59836 [details] [diff] [review]
Fix js error at startup on Mac (-uw)
(Reporter)

Comment 9

16 years ago
Comment on attachment 59836 [details] [diff] [review]
Fix js error at startup on Mac (-uw)

r=sfraser
Attachment #59836 - Flags: review+

Comment 10

16 years ago
Comment on attachment 59836 [details] [diff] [review]
Fix js error at startup on Mac (-uw)

sr=hewitt
Attachment #59836 - Flags: superreview+
(Assignee)

Comment 11

16 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
don't see this error in the js console after startup. vrfy'd fixed on mac 10.1.1
and 9.1 with 2001.12.05.0x comm verif bits.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.