Move the nsPlacesAutocomplete component to Suite (comm-central part)

RESOLVED FIXED in seamonkey2.49

Status

SeaMonkey
Autocomplete
RESOLVED FIXED
3 years ago
10 months ago

People

(Reporter: mak, Assigned: Philip Chee)

Tracking

Trunk
seamonkey2.49
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.49esr fixed)

Details

User Story

nsPlacesAutocomplete won't be anymore part of Places, for now I'm gating it behind a if CONFIG['MOZ_SUITE'] but it should really be moved to the suite itself along with the tests under unit/tests/autocomplete.

Bug 1281005 (mozilla-central) remove nsPlacesAutocomplete component and tests:
https://hg.mozilla.org/mozilla-central/rev/9792d02838ac

Import nsPlacesAutocomplete with history to comm-central:
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=75c57c9dc363&tochange=9bd937fc0c12

Start building nsPlacesAutocomplete as part of suite:
http://hg.mozilla.org/comm-central/rev/af0e89924350

Attachments

(2 attachments, 3 obsolete attachments)

Once we are satisfied with unified complete, and it's unlikely to be disabled, we should remove the 2 old components from the tree.
Flags: firefox-backlog+
Comment hidden (off-topic)
Comment hidden (obsolete)
Comment hidden (obsolete)
Duplicate of this bug: 1169985

Updated

2 years ago
Rank: 32
Blocks: 1210005
Summary: Stop bundling the old autocomplete search components → Stop bundling the old autocomplete search components in Firefox

Comment 5

2 years ago
I'm sorry, are you going to delete that pref anyway, no matter how many "edgecases" are left aside?
The same happened with the searchbar, and now we got unusable thing. Maybe it's not necessary to completely delete/KILL/exterminate! what worked tolerably for years? I believe the pref should stay
http://ssmaker.ru/661fb42e.png
Comment hidden (off-topic)
Depends on: 1223728

Comment 7

2 years ago
Is this bug to remove the browser.urlbar.unifiedcomplete preference? Please don't. Firefox v43 introduced a rather irritating "Visit Site..." dropdown in the URL bar and this preference was the only knob to turn this off.
Comment hidden (off-topic)

Comment 9

2 years ago
unhelpful
(In reply to Marco Bonardo [::mak] from comment #8)
> (In reply to Christian Kujau from comment #7)
> > Is this bug to remove the browser.urlbar.unifiedcomplete preference? Please
> > don't. Firefox v43 introduced a rather irritating "Visit Site..." dropdown
> > in the URL bar and this preference was the only knob to turn this off.
> 
> You can just use a userChrome.css customization to hide it if it's so
> annoying to you. But I'd suggest to try to get used to it first.

It is right that this "Visit site" dropdown or "search with ..." stuff is completely useless.
I don't hide it for now but it's an useless function.
Comment hidden (advocacy)
Comment hidden (off-topic)
Morphing the bug since the Firefox part will happen in bug 1223728.

nsPlacesAutocomplete won't be anymore part of Places, for now I'm gating it behind a if CONFIG['MOZ_SUITE'] but it should really be moved to the suite itself along with the tests under unit/tests/autocomplete.
User Story: (updated)
Component: Places → Bookmarks & History
Flags: firefox-backlog+
Priority: P3 → --
Product: Toolkit → SeaMonkey
Summary: Stop bundling the old autocomplete search components in Firefox → Move the nsPlacesAutocomplete component to Suite.
Whiteboard: [unifiedcomplete][fxsearch]
Component: Bookmarks & History → Autocomplete
No longer blocks: 1210005
note that alternatively you can move to UnifiedComplete.js, you should be able to obtain similar results as the old search setting some prefs (like disabling autoFill, not setting "enable-actions" searchparam...)
See Also: → bug 1271241
(Assignee)

Comment 14

a year ago
(In reply to Marco Bonardo [::mak] from comment #13)
> note that alternatively you can move to UnifiedComplete.js, you should be
> able to obtain similar results as the old search setting some prefs (like
> disabling autoFill, not setting "enable-actions" searchparam...)

That would be optimum however I don't know how to switch to that. Is there a Dummies Guide?
replace "history" and set browser.urlbar.autoFill to false (but looks like it's already the default), may be enough. But you should test it.
Looks like you are exposing autoFill http://mxr.mozilla.org/comm-central/source/suite/common/pref/pref-locationbar.xul#34 so maybe you want to try both cases.
The fact the inputfield doesn't have "enable-actions" in the searchparams attribute should filter out most of the special unifiedcomplete actions, so you should be fine (there may be bugs I don't know, for example I just fixed search suggestions to be skipped in that case in Nightly).

So I think it's mostly matter of testing.
(Assignee)

Updated

a year ago
Flags: needinfo?(philip.chee)
(Assignee)

Updated

a year ago
Depends on: 1281005
(Assignee)

Updated

a year ago
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Flags: needinfo?(philip.chee)
Summary: Move the nsPlacesAutocomplete component to Suite. → Move the nsPlacesAutocomplete component to Suite (comm-central part)
(Assignee)

Comment 16

a year ago
Created attachment 8783221 [details] [diff] [review]
patch v1 comm-central

See Bug 1281005 attachment 8763697 [details] [diff] [review] for the mozilla-central part. Unless you want to import the history too...
Attachment #8783221 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 17

a year ago
Created attachment 8784328 [details]
filemap.txt import/convert nsPlacesAutocomplete with history
Attachment #8784328 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 18

a year ago
Created attachment 8784329 [details] [diff] [review]
Patch v2 changes to moz.build and test files after history import

moz.build and unit test changes.
Attachment #8783221 - Attachment is obsolete: true
Attachment #8783221 - Flags: review?(iann_bugzilla)
Attachment #8784329 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 19

a year ago
Created attachment 8784349 [details]
mercurial bundle containing the intermediate repository created by Mercurial Convert
Attachment #8784349 - Flags: feedback?(iann_bugzilla)
(Assignee)

Comment 20

a year ago
Created attachment 8786842 [details]
nsPlacesAutocomplete.zip

Contents of nsPlacesAutocomplete.zip:

 1/09/2016   0:49       3,966,463  places-inbound.bundle
 1/09/2016   0:52         158,934  suite-inbound.bundle
26/08/2016  23:33              99  filemapA.txt
27/08/2016  23:44             847  filemapB.txt
31/08/2016  23:41              84  splicemap.txt
 1/09/2016   0:29             166  splicemapB.txt
 1/09/2016   0:57              66  splicemapC.txt
 1/09/2016   1:04           1,733  notes1.txt

notes:

Step 1:
hg convert --filemap filemapA.txt --config convert.skiptags=true mozilla-inbound places-inbound
Step 2:
hg convert --filemap filemapB.txt --splicemap splicemapB.txt --config convert.skiptags=true places-inbound  suite-inbound2

Step 3: rebase/linearize on suite-inbound2:
hg strip -r 197
hg strip -r 141
rebase .... etc

Step 4: land on comm-central:
hg convert --splicemap splicemapC.txt --config convert.skiptags=true  suite-inbound2  comm-aurora

filemapA.txt:
include toolkit/components/places/
rename  toolkit/components/places/     suite/common/places/

filemapB.txt:
include    suite/common/places/src/nsPlacesAutoComplete.js
include    suite/common/places/src/nsPlacesAutoComplete.manifest
#
include    suite/common/places/nsPlacesAutoComplete.js
include    suite/common/places/nsPlacesAutoComplete.manifest
#
include    suite/common/places/tests/autocomplete/
include    suite/common/places/tests/autocomplete/
#
include    suite/common/places/tests/head_common.js
include    suite/common/places/tests/unit/test_416211.js
include    suite/common/places/tests/unit/test_416214.js
include    suite/common/places/tests/unit/test_417798.js
include    suite/common/places/tests/unit/test_418257.js
include    suite/common/places/tests/unit/test_422277.js
include    suite/common/places/tests/unit/test_multi_word_search.js
include    suite/common/places/tests/unit/test_word_boundary_search.js

splicemapB.txt:
e0144251aef999bf4a24f20ec8af020f9efd4257 30c920b20c526fe4fbff7cce43553fe7f495a286
35245876fac0bc646bf9bae6d002d75de3283115 0fdee75a305a09d1ff7f0799a4718db92368f3bc

splicemapC.txt:
first_changeset_of_suite-inbound2 last_changeset_of_comm-central
Attachment #8784328 - Attachment is obsolete: true
Attachment #8784349 - Attachment is obsolete: true
Attachment #8784328 - Flags: review?(iann_bugzilla)
Attachment #8784349 - Flags: feedback?(iann_bugzilla)
Attachment #8786842 - Flags: feedback?(iann_bugzilla)
(Assignee)

Comment 21

a year ago
> Step 4: land on comm-central:
> hg convert --splicemap splicemapC.txt --config convert.skiptags=true  suite-inbound2  comm-central

Hint: You might want to test this several times, using hg strip to get back to a clean comm-central tree. However this won't work in subsequent attempts unless you delete the comm-central/.hg/shamap file created by convert each time.

Comment 22

11 months ago
Comment on attachment 8784329 [details] [diff] [review]
Patch v2 changes to moz.build and test files after history import

LGTM r/a=me
Attachment #8784329 - Flags: review?(iann_bugzilla) → review+

Comment 23

11 months ago
Comment on attachment 8786842 [details]
nsPlacesAutocomplete.zip

Seems to have all the correct file in the right place f=me
Attachment #8786842 - Flags: feedback?(iann_bugzilla) → feedback+

Comment 24

11 months ago
suite/common/places/moz.build will need a few tweaks:
LOCAL_INCLUDES
include
with Files
(Assignee)

Comment 25

11 months ago
Pushed nsPlacesAutocomplete with history import with history from mozilla-central:
Pushlog: http://hg.mozilla.org/comm-central/pushloghtml?fromchange=75c57c9dc363&tochange=9bd937fc0c12

Will push Part 2 (attachment 8784329 [details] [diff] [review]) once the removal patch hits mozilla-central
(https://hg.mozilla.org/integration/mozilla-inbound/rev/9792d02838ac)
(Assignee)

Comment 26

11 months ago
Patch to start building nsPlacesAutocomplete in Suite:
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/af0e89924350
(Assignee)

Updated

11 months ago
User Story: (updated)
(Assignee)

Updated

11 months ago
status-seamonkey2.49esr: --- → fixed
Target Milestone: --- → seamonkey2.49
(Assignee)

Updated

10 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.