Closed Bug 995097 Opened 7 years ago Closed 6 years ago

Contact photos are not always imported. Bug 970832 did not fix the problem

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog, b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 fixed, b2g-v2.2 verified, b2g-v2.5 verified, b2g-master verified)

VERIFIED FIXED
1.4 S5 (11apr)
tracking-b2g backlog
Tracking Status
b2g-v1.3 --- affected
b2g-v1.4 --- affected
b2g-v2.0 --- fixed
b2g-v2.2 --- verified
b2g-v2.5 --- verified
b2g-master --- verified

People

(Reporter: jmcf, Assigned: crdlc)

References

Details

Attachments

(1 file)

Bug 970832 did not totally fix the problem of contact photo importation. I'm still suffering the problem with latest master. Here we may have one of two problems:

a/ window.stop
b/ Gecko issue
blocking-b2g: --- → 1.4?
Summary: Contact photos are not always imported. Bug 970832 did not fixt he problem → Contact photos are not always imported. Bug 970832 did not fix the problem
blocking-b2g: 1.4? → 1.3?
Cristian,

I have assigned to you but as you will be on vacation next week, other people might feel free to take it (provided we don't fix it promptly).


thanks
Assignee: nobody → crdlc
Attached file Patch v1
This patch fixes the problem about window.stop() in image loader component. The problem was in the imageLoader in the contact lists instead of import UI. While the device is importing, new contacts are added to the list and the 'scroll' event is fired so the window.stop() is performed on the list penalizing some images randomly. I have to implement a couple of unit tests. But I've added a console.log close to window.close() in my local code and it is never called while importing. Do you want to test this patch Jose?
Attachment #8405231 - Flags: feedback?(jmcf)
Comment on attachment 8405231 [details]
Patch v1

I've already implemented a new unit test so asking for review better than feedback
Attachment #8405231 - Flags: feedback?(jmcf) → review?(jmcf)
Comment on attachment 8405231 [details]
Patch v1

excellent job, Cristian. Tested it and works ok. 

many thanks and congrats!
Attachment #8405231 - Flags: review?(jmcf) → review+
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/a72bf2d2704092c9e2634fc1458f5c31a422d820
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S5 (11apr)
Flags: in-testsuite+
Comment on attachment 8405231 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 970832 didn't fix all the possible code paths that could lead to invoke window.stop and to break images retrieval 
[User impact] if declined: High. Contacts importation will be perceived as buggy and broken
[Testing completed]: Basic testing on master. qawanted for thourough testing before landing on 1.3 and 1.4 branches
[Risk to taking this patch] (and alternatives if risky): Low-risk patch
[String changes made]:
Attachment #8405231 - Flags: approval-gaia-v1.3?(release-mgmt)
Keywords: qawanted, verifyme
Keywords: qawanted
What scenarios are we trying to fix here?

Beatriz,

Is this an IOT for TEF?
Flags: needinfo?(brg)
Keywords: qawanted
Keywords: qawanted
(In reply to Preeti Raghunath(:Preeti) from comment #7)
> What scenarios are we trying to fix here?
> 
Good question!

> Beatriz,
> 
> Is this an IOT for TEF?
It has not been reported during IOT process.
Flags: needinfo?(brg)
Backlog for now, lets monitor for now.
blocking-b2g: 1.3? → backlog
The scenario/problem here is that sometimes when a user imports contacts from Facebook or Gmail not all the contacts photos will be imported. I don't even know it that's tested (importing contacts from Facebook/gmail) at certification or not though.
Comment on attachment 8405231 [details]
Patch v1

Clearing the nom here as I read any signs of this being a blocker for 1.3
Attachment #8405231 - Flags: approval-gaia-v1.3?(release-mgmt)
Blocks: 998905
If this bug is uplifted finally, you have to uplift the bug 995097 which fixes a regression introduced here
(In reply to Cristian Rodriguez (:crdlc) from comment #12)
> If this bug is uplifted finally, you have to uplift the bug 995097 which
> fixes a regression introduced here

are you referring to Bug 998905, right?
Flags: needinfo?(crdlc)
yep, sorry, copy&paste :)
Flags: needinfo?(crdlc)
No longer blocks: 998905
Depends on: 998905
blocking-b2g: backlog → ---
QA Contact: sleedavid
No Repro per build(s): 

RESULT: 
When create a new contact, and add an image, the image imports in to contact page, shows up on the Contacts page when viewed in the Contact App. 

Environmental Variables:
Device: Aries 2.6
BuildID: 20151120133504
Gaia: 94a821b49f4dca3f9321cd80e13c44c4a6696952
Gecko: ec628289d8b4ed310463a0729c3e60a7798dfcac
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Aries 2.5
BuildID: 20151119161838
Gaia: 28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5
Gecko: 497118efc1414c2825a8bd17b38721888c3875ca
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.6
BuildID: 20151120030231
Gaia: 94a821b49f4dca3f9321cd80e13c44c4a6696952
Gecko: 3835b568092ae3b71adc931d24928670ad7141a7
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20151120073427
Gaia: b7f130c36588e308784cd1b7c8a28585c9819076
Gecko: 589a9b96c5bc632bcc336d0543442983cc1f61dd
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: verifyme
Comment 15 is not what this bug was about.  This bug is about importing contacts from another source that already have images.
Status: VERIFIED → RESOLVED
Closed: 7 years ago6 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: verifyme
RESULT: No Repro per branch
Contact pictures import from gmail accounts to the device.   

Environmental Variables:
Device: Flame 2.6  (no repro)
BuildID: 20151218030236
Gaia: 2f093462969d2c5f65dced3908a7abff6b1913e8
Gecko: 66fb852962c0d5f6f5fe0604204da4f5d17763c9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 (2.6) 
Firmware Version: v18D


Environmental Variables:
Device: Aries 2.6  (no repro)
BuildID: 20151221131907
Gaia: 14aefb2519becfa32f31bcc3c9c995693421f19c
Gecko: a8acaa9868df4aa8d801725cfa9ef744640fc402
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf

Environmental Variables:
Device: Flame 2.5 (no repro)
BuildID: 20151023030241
Gaia: 410e91ddabc7ba82a9b43b3711a3fdf2cb8de309
Gecko: 0625c68c0abcfe4d10880d15d8fe7d06df3369c9
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a1 (2.5) 
Firmware Version: v18D

Environmental Variables:
Device: Flame 2.2   (no repro)
BuildID: 20151218032501
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 2120b3e6f680
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 37.0 (2.2) 
Firmware Version: v18D
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.