Closed Bug 995263 Opened 10 years ago Closed 10 years ago

table cell borders not visible when background-color is set

Categories

(Firefox :: Untriaged, defect)

28 Branch
x86_64
Windows Server 2008
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 688556

People

(Reporter: alexmoreno, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140314220517

Steps to reproduce:

1. Create a table with borders (via border="1" or CSS td {border: 1px solid} table {border-collapse: collapse})
2. Add style="background-color: #f3f3f3" to a single TD.


Actual results:

The cell with a background-color will cease to display a border properly.
It may only show the top+left borders, or it may not show any borders, depending on the position of the cell with respect to the table.


Expected results:

Both the background-color and the border should be visible.
Personally tested on Windows Server 2008, but have reports of this bug on OS X as well.
OS: Windows 7 → Windows Server 2008
*Missed information about css position in OP*
*Updated here*

Steps to reproduce:

1. Create a table with borders (via border="1" or CSS td {border: 1px solid} table {border-collapse: collapse})
2. Add style="background-color: #f3f3f3; position: relative;" to a single TD.


Actual results:

The cell with relative position and a background-color will cease to display a border properly.
It may only show the top+left borders, or it may not show any borders, depending on the position of the cell with respect to the table.


Expected results:

Both the background-color and the border should be visible.
[bugday-20140416]
This seems to be a duplicate of bug 688556.
https://bugzilla.mozilla.org/show_bug.cgi?id=688556
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.