Trunk crash [@ nsXULAttributeValue::SetValue]

RESOLVED DUPLICATE of bug 86783

Status

()

Core
XUL
--
critical
RESOLVED DUPLICATE of bug 86783
17 years ago
10 years ago

People

(Reporter: jay, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This is showing up in recent MozillaTrunk Talkback topcrash reports:

nsXULAttributeValue::SetValue   19 
BBID range: 34943929 - 35303882
Min/Max Seconds since last crash: 0 - 45
Min/Max Runtime: 0 - 48
Crash data range: 2001-09-04 to 2001-09-12
Build ID range: 2001090410 to 2001091209

Stack Trace: 

	 nsXULAttributeValue::SetValue
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULAttributeValue.cpp 
line 78]
	 nsXULAttribute::SetValueInternal
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULAttributes.cpp  line 527]
	 nsXULAttribute::nsXULAttribute
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULAttributes.cpp  line 216]
	 nsXULAttribute::Create
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULAttributes.cpp  line 240]
	 nsXULElement::SetAttr
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line 3002]
	 nsXULElement::SetAttribute
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line 1434]
	 nsXULElement::SetTooltipText
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp  line 4818]
	 XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp 
line 139]
	 XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp  line 1954]
	 XPC_WN_GetterSetter
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp 
line 1287]
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 809]
	 js_InternalInvoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 900]
	 js_GetProperty
[d:\builds\seamonkey\mozilla\js\src\jsobj.c  line 2413]
	 js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2559]
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 825]
	 js_InternalInvoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 900]
	 JS_CallFunctionValue
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3362]
	 nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp  line 960]
	 nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp  line 140]
	 nsXBLPrototypeHandler::ExecuteHandler
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLPrototypeHandler.cpp  line 433]
	 nsXBLPrototypeHandler::BindingAttached
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLPrototypeHandler.cpp  line 481]
	 nsXBLPrototypeBinding::BindingAttached
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLPrototypeBinding.cpp  line 565]
	 nsXBLBinding::ExecuteAttachedHandler
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLBinding.cpp  line 1134]
	 nsBindingManager::ProcessAttachedQueue
[d:\builds\seamonkey\mozilla\content\xbl\src\nsBindingManager.cpp  line 1283]
	 nsCSSFrameConstructor::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 8645]
	 StyleSetImpl::ContentInserted
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp  line 1181]
	 PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 2626]
	 HTMLContentSink::StartLayout
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp 
line 3862]
	 HTMLContentSink::OpenBody
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp 
line 3147]
	 CNavDTD::OpenBody
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 3107]
	 CNavDTD::OpenContainer
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 3361]
	 CNavDTD::HandleDefaultStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 1290]
	 CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 1696]
	 CNavDTD::HandleToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 881]
	 CNavDTD::BuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 512]
	 nsParser::BuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 1993]
	 nsParser::ResumeParse
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 1857]
	 nsParser::OnStopRequest
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 2492]
	 nsDocumentOpenInfo::OnStopRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp  line 257]
	 nsStreamIOChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp  line 462]
	 nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp  line 162]
	 PL_HandleEvent
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 591]
	 PL_ProcessPendingEvents
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 524]
	 _md_EventReceiverProc
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072]
	 nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp  line 442]
	 main1
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1283]
	 main
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1600]
	 WinMain
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1618]
	 WinMainCRTStartup()
	 KERNEL32.DLL + 0x17d08 (0x77e97d08)
 
 	Source File :
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/content/xul/content/src/nsXULAttributeValue.cpp
line : 78
     (35233520)	Comments: Starting up newest nightly build (0910xx) 
     (35141439)	Comments: If I copy the NEW Mozilla build over the old  anything above
8-1-2001 crashes with a Page Fault.  However  if I use the Build by itself
without copying it over  it works  but Javascript does not work.  Commands such
as OnMouseOver and OnMouseOut no longer
     (35141439)	Comments:  function.  8-1-2001 supports these commands and others similar to
it.  Also  the 8-1-2001 build has a memory leak in it  which I am not sure has
been addressed in newer builds.  I noticed the leak when I downloaded multiple
files from the internet using
     (35141439)	Comments:  the SAVE dialog.  Also  the SAVE dialog does not remember the
settings that you choose either.
     (35083231)	URL: http://www.libsdl.org
(35035773)
Comments: Installed nightly  overwrote existing files  including configuration
files.  Access violation at launch.
I'm not sure which component this falls under, so please direct this bug in the
right direction.  This is a Win32 crash, Talkback incidents show this occurring
on Win98, WinNT, Win2k and WinME.
I believe this is a duplicate of bug 86783.  See my 2001-09-05 comments there.
(Assignee)

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 86783 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.