Closed Bug 995479 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Browser]Browsing resource heavy webpages makes the Tarako unresponsive and may result in a "this is embarassing" error message.

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 991084
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: jmitchell, Unassigned)

Details

(Whiteboard: [tarako-exploratory], 1.3tarakorun2, OOM)

Attachments

(2 files)

Attached file firewatch_Surfing.txt
Description:
 Browsing webpages on the Tarako results in a lot of lag and unresponsive behavior. Webpages with videos or pictures take a long time to load, cause the browser to become unresponsive, and may result in an error message. "Well, this is embarassing. We tried to display this web page, but it's not responding" was given after attempting to load the page for several minutes. Most of the content was loaded but the video and pictures would appear and sometimes disappear until encountering the error message.
* http://www.cnn.com/2014/04/11/politics/sebelius-feature/index.html
was the website that gave the error message after attempting to load.

Repro Steps:
1) Update a Tarako to BuildID: 20140411004003
2) Launch the Browser
3) Browse the web to resource heavy webpages
4) Examples - news websites such as CNN.com
Actual:
Lag and hitches, error message
Expected:
Navigation to the intended webpage in a reasonable amout of time.

1.3T Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140411004003
Gaia: 27a0e773e01eed74e20709bdcab6894469f42a72
Gecko: 257dd37da601
Version: 28.1
Firmware Version: SP6821

Repro frequency: 100%
See attached: logcat.txt, firewatch_surfing.txt
Attached file logcat.txt
Flags: needinfo?(nhirata)
Whiteboard: [tarako-exploratory] → [tarako-exploratory], 1.3tarakorun2
How is this a bug on our side? This is a low memory device, so there's going to be a bunch of cases where the content errors out due to an OOM. CNN also specifically is already known for consuming a lot of memory.

This is likely a dupe of bug 991084, as CNN is known for consuming high memory.
Flags: needinfo?(jmitchell)
This bug was prompted by an email from Naoki on the 11th to all testers stating "Please report any bugs that you feel is bad in terms of performance / usability of the device and need info me on that bug.
i.e. like it takes 5 seconds for the dialer ui to come up ( which is already reported)"

Later we were asked to provide feedback on the Tarako and browsing was an issue that was often cited as a "pain-point"; and so it was decided a bug should be put in on it to see if there was anything that could be done on our side.

CNN was just an example site that I randomly encountered, really any news-feed style of site can cause similar issues.
Flags: needinfo?(jmitchell)
I'm not sure this is really an actionable bug. I'll wait for Naoki to comment here on what he wants to do here.
Thanks for calling this out, Joshua.  Even though I'll dupe it to 991084, these kinds of bugs are helpful for us to see how the low memory issues are affecting testing.  Keep them coming. Thanks.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(nhirata)
Resolution: --- → DUPLICATE
Whiteboard: [tarako-exploratory], 1.3tarakorun2 → [tarako-exploratory], 1.3tarakorun2, OOM
Duplicate of bug: 991084
You need to log in before you can comment on or make changes to this bug.