Closed Bug 995511 Opened 7 years ago Closed 7 years ago

[l10n][gl] Use Spanish layout keyboard by default for gl

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: tchevalier, Assigned: tchevalier)

References

Details

(Whiteboard: LocRun1.4)

Attachments

(1 file)

It seems we don't have any keyboard layout for gl (Galician) locale.
We talked on IRC with Keko, he told me users are expecting a Spanish layout (Which makes sense :) )

flod pointed me to this config file https://github.com/mozilla-b2g/gaia/blob/master/build/config/keyboard-layouts.json

Currently, English layout is defined by default for Galician.
I will update it as follow:

    "gl": [
        {"layoutId": "es", "app": ["apps", "keyboard"]}
    ],
Summary: [l10n][gl] Missing keyboard for gl → [l10n][gl] Use Spanish layout keyboard by default for gl
Assignee: nobody → tchevalier
Status: NEW → ASSIGNED
Attachment #8406232 - Flags: review?(rlu)
Comment on attachment 8406232 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/18291

This patch looks good to me.
However, the travis is failed, and I just triggered it to re-run.
Let's see how it goes.

Thanks.
Attachment #8406232 - Flags: review?(rlu) → review+
The travis is all green.

Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/6c984a6c3090a9b592b0be3209c102235669adab
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1077043
You need to log in before you can comment on or make changes to this bug.