Closed Bug 995597 Opened 8 years ago Closed 8 years ago

[tarako]When b2g killed by LMK/OOM, b2g need quick restart without boot animation

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:-)

RESOLVED DUPLICATE of bug 999953
blocking-b2g -

People

(Reporter: james.zhang, Unassigned)

Details

(Whiteboard: OOM)

Attachments

(1 file)

When b2g killed by OOM, b2g need quick restart without boot animation.
Our QA summit a lot of critical issue because it seems system restart.
blocking-b2g: --- → 1.3T?
Flags: needinfo?(ttsai)
Flags: needinfo?(styang)
Flags: needinfo?(kkuo)
Flags: needinfo?(jcheng)
Flags: needinfo?(fabrice)
We could suppress the boot animation, but that will not make us start faster. This animation runs off the main thread: https://mxr.mozilla.org/mozilla-central/source/widget/gonk/libdisplay/BootAnimation.cpp#575
Flags: needinfo?(fabrice)
And by supressing the boot animation, I mean doing that only on "restarts".
Is b2g killed by OOM a normal use case? Or does killing b2g by OOM only happen in Monkey test?
Flags: needinfo?(ttsai)
(In reply to thomas tsai from comment #3)
> Is b2g killed by OOM a normal use case? Or does killing b2g by OOM only
> happen in Monkey test?

It not only happen in monkey test. Sometimes QA found it restart and submit critical bug in my bugzilla.
LMK and OOM also can kill b2g, it likes system crash and restart.
We should protect b2g and nuwa process.
Why not kill foreground apps and preallocated process?

04-12 10:24:09.265 <4>0[  643.664651] lowmem_shrink select 83 (b2g), adj 0, size 28068, to kill
04-12 10:24:09.265 <4>0[  643.664745] lowmem_shrink send sigkill to 83 (b2g), adj 0, size 28068
Summary: [tarako]When b2g killed by OOM, b2g need quick restart without boot animation → [tarako]When b2g killed by LMK/OOM, b2g need quick restart without boot animation
b2g killed by LMK log
Can I change kernel CONFIG_SLAB to CONFIG_SLOB for shrink memory?
Hi James: what's the impact between slab and slob? how confident in your kernel team can evaluate this change?
We have to fix why b2g is killed. At that moment, all low priority processes should be killed and the memory is still not enough, so b2g is finally killed. We have to confirm this scenario.
And the project time is getting short, is it too risky to change kernel's slab and slob?
+1

(In reply to thomas tsai from comment #10)
> We have to fix why b2g is killed. At that moment, all low priority processes
> should be killed and the memory is still not enough, so b2g is finally
> killed. We have to confirm this scenario.
> And the project time is getting short, is it too risky to change kernel's
> slab and slob?
Flags: needinfo?(kkuo)
triage: b2g should not be killed, lets focus on why b2g is killed , not blocking
blocking-b2g: 1.3T? → -
Flags: needinfo?(jcheng)
Flags: needinfo?(styang)
Duping this to 999953, as fixing the other fixes this.   I'm watching the other bug as well and plan to  test both STRs
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 999953
You need to log in before you can comment on or make changes to this bug.