Non-english address book problem?

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Rob Kearey, Assigned: chuang)

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Sending an email to a user with a non-western character set (in this case,
Korean), seems to give a malformed mail heard which the MTA chokes on.

Example:

The original message was received at Fri, 14 Sep 2001 17:03:03 +1000
from rkearey.brisbane.redhat.com [172.16.5.96]

   ----- The following addresses had permanent fatal errors -----
<"=?ISO-8859-1?Q?=3F=3F=3F?=(David">
(reason: 550 <"=?iso-8859-1?q?=3f=3f=3f?=(david"@mail.corp.redhat.com>... User
unknown)
    (expanded from: <"=?ISO-8859-1?Q?=3F=3F=3F?=(David">)
<"Joo)">
(reason: 550 <"joo)"@mail.corp.redhat.com>... User unknown)
    (expanded from: <"Joo)">)

   ----- Transcript of session follows -----
... while talking to mx.corp.redhat.com.:

>>> RCPT To:<"joo)"@mail.corp.redhat.com>

<<< 550 <"joo)"@mail.corp.redhat.com>... User unknown
550 5.1.1 <"Joo)">... User unknown

>>> RCPT To:<"=?iso-8859-1?q?=3f=3f=3f?=(david"@mail.corp.redhat.com>

<<< 550 <"=?iso-8859-1?q?=3f=3f=3f?=(david"@mail.corp.redhat.com>... User unknown
550 5.1.1 <"=?ISO-8859-1?Q?=3F=3F=3F?=(David">... User unknown



Reporting-MTA: dns; hypatia.brisbane.redhat.com
Received-From-MTA: DNS; rkearey.brisbane.redhat.com
Arrival-Date: Fri, 14 Sep 2001 17:03:03 +1000

Final-Recipient: RFC822;
<"=?ISO-8859-1?Q?=3F=3F=3F?=(David">@hypatia.brisbane.redhat.com
X-Actual-Recipient: RFC822; "=?iso-8859-1?q?=3f=3f=3f?=(david"@mail.corp.redhat.com
Action: failed
Status: 5.1.1
Remote-MTA: DNS; mx.corp.redhat.com
Diagnostic-Code: SMTP; 550
<"=?iso-8859-1?q?=3f=3f=3f?=(david"@mail.corp.redhat.com>... User unknown
Last-Attempt-Date: Fri, 14 Sep 2001 17:03:08 +1000

Final-Recipient: RFC822; <"Joo)">@hypatia.brisbane.redhat.com
X-Actual-Recipient: RFC822; "joo)"@mail.corp.redhat.com
Action: failed
Status: 5.1.1
Remote-MTA: DNS; mx.corp.redhat.com
Diagnostic-Code: SMTP; 550 <"joo)"@mail.corp.redhat.com>... User unknown
Last-Attempt-Date: Fri, 14 Sep 2001 17:03:07 +1000

Comment 1

16 years ago
Shirley, do you know who should be assigned this bug?
QA Contact: nbaca → ji

Comment 2

16 years ago
Rob, have you sent the mail in Korean (switching to Korean encoding by selecting
View | Character Coding before sending)? From your description, it seems you had
a Korean recipient name but sent out in western encoding (iso-8859-1). In this
case, you still should be able to send out mails although the recipient name
won't be displayed correctly after mail is received. And this is the result I
got with 09/17 0.9.4 build.
Keywords: intl

Comment 3

16 years ago
Ninoschka, after this bug is confirmed, this will be reassigned to i18n team.

Comment 4

16 years ago
Also because of bug # 44313 ( there is no warning for From/To/Organizatin fields
when the charset is different from body or/and headers) it is easy to overlook
it when sending a message.

Comment 5

16 years ago
Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
reopening. Reporter, is this bug still occurring?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

16 years ago
This seems to have been fixed so far.

Comment 8

16 years ago
Marked it as wfm. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
Verified as such.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.