Bookmark importer mangles accented characters (8-bit characters)

VERIFIED DUPLICATE of bug 88779

Status

VERIFIED DUPLICATE of bug 88779
18 years ago
14 years ago

People

(Reporter: santtu, Assigned: bugs)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808
BuildID:    2001080814

When importing Netscape 4 bookmarks, the bookmark importer mangles accented
characters into incomperhensible junk, which in the end are shown as "?"
characters by the mozilla bookmark menu et al.

Reproducible: Always
Steps to Reproduce:
1. mkdir /tmp/xx
2. export HOME=/tmp/xx
3. cd
4. netscape
5. open bookmarks, delete all entries, add entries with accented characters
(iso-8859-1 encoding)
6. exit netscape
7. start mozilla
8. click accept (to convert profile)
9. look at bookmarks
10. compare netscape's bookmarks.html and mozilla's bookmarks.html

Actual Results:  Incorrect display in mozilla, funny characters in
bookmarks.html file.

Expected Results:  To import the existing bookmarks as they should be. If
mozilla is not sure which character set the original bookmark file was in, it
should prompt the user, or at least not mangle them incomperhensible.

I'll attach the original netscape bookmark file and generated mozilla bookmark file.
(Reporter)

Comment 1

18 years ago
Created attachment 49317 [details]
Original netscape 4.77 bookmarks.html file.
(Reporter)

Comment 2

18 years ago
Created attachment 49318 [details]
Mozillas converted bookmarks.html file
(Reporter)

Comment 3

18 years ago
Oh, and notice also that in this case the importer also removed one bookmark
completely,apparently because it had empty HREF (<A HREF="" ...>).
(Reporter)

Comment 4

18 years ago
I tested the same procedure with build 2001091321, and the accented characters
were correctly converted into UTF-8 encoding.

However, it still removed the bookmark with empty HREF. Whether that is a bug or
a  valid feature, I cannot say...

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 88779 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.