Closed Bug 996121 Opened 5 years ago Closed 5 years ago

Bouncing unicorn easter egg (in hamburger menu) briefly triggers scrollbar each time it hits the bottom of its bounce area

Categories

(Firefox :: Toolbars and Customization, defect)

All
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 --- wontfix
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: dholbert, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P5])

Attachments

(3 files)

Attached video screencast
STR:
 1. Click hamburger button, click customize, and drag everything out of the panel to leave it empty.

 2. Click "Exit customize"

 3. Click hamburger button again.

 4. Wait for the bouncing unicorn to hit its lowest point.

ACTUAL RESULTS: A scrollbar briefly flashes when it hits the lowest point.
EXPECTED RESULTS: No scrollbar
Attached image screenshot
I'm pretty sure this is Linux only. We may need to tweak some of the sizes for Linux.
Version info: 31.0a1 (2014-04-12)
Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0
I can confirm this only affects Linux platform, both 32bit and 64bit architectures.
Hardware: x86_64 → All
Summary: Bouncing unicorn easter egg (in hamburger menu) briefly triggers scrollbar each time it hits the bottom of its bounce area → [Linux] Bouncing unicorn easter egg (in hamburger menu) briefly triggers scrollbar each time it hits the bottom of its bounce area
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Summary: [Linux] Bouncing unicorn easter egg (in hamburger menu) briefly triggers scrollbar each time it hits the bottom of its bounce area → Bouncing unicorn easter egg (in hamburger menu) briefly triggers scrollbar each time it hits the bottom of its bounce area
Attached patch PatchSplinter Review
Attachment #8407074 - Flags: review?(mconley)
To clarify, this bug is caused by the different default font size on Linux as compared to OSX and Windows. This patch should makes this animation font-size agnostic.
Comment on attachment 8407074 [details] [diff] [review]
Patch

LGTM
Attachment #8407074 - Flags: review?(mconley) → review+
https://hg.mozilla.org/mozilla-central/rev/0423a8e32248
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 31
Whiteboard: [Australis:P5]
Comment on attachment 8407074 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): incorrect assumption in initial implementation, bug 934075
User impact if declined: scrollbar will appear briefly on linux
Testing completed (on m-c, etc.): on m-c for a day now, and tested locally
Risk to taking this patch (and alternatives if risky): none expected
String or IDL/UUID changes made by this patch: none
Attachment #8407074 - Flags: approval-mozilla-aurora?
Attachment #8407074 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Whiteboard: [good first verify]
Duplicate of this bug: 1003780
Flags: in-testsuite?
Flags: in-testsuite? → in-testsuite-
Flags: in-qa-testsuite?
Flags: in-qa-testsuite?
You need to log in before you can comment on or make changes to this bug.