Main window briefly shows flat background color during customize mode transition

VERIFIED FIXED in Firefox 29

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mconley, Assigned: mconley)

Tracking

(Depends on 1 bug)

Trunk
Firefox 31
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29+ verified, firefox30+ verified, firefox31 verified)

Details

(Whiteboard: [Australis:P3+])

Attachments

(1 attachment, 1 obsolete attachment)

This is fallout from bug 973694 - we're temporarily showing the old private browsing mode flat colour during the customize mode transition.

Looks like ass. Patch coming up.
(Assignee)

Comment 1

5 years ago
Posted patch Patch v1 (obsolete) — Splinter Review
Should have caught this the first time around.

Basically, we set the -moz-appearance of the #titlebar to none in order to make so that we can apply a nice textured background to it (the grid) in customize mode. We only need to do that on customize-entered, since this is when the grid is applied. Before then, we should keep the titlebar around.

We can discount LWT's, because during the transition, LWT's have been unapplied.

Requesting review from either Gijs or MattN. I'll let you two duke it out.
Attachment #8406382 - Flags: review?(gijskruitbosch+bugs)
Attachment #8406382 - Flags: review?(MattN+bmo)
(Assignee)

Comment 2

5 years ago
This doesn't break anything functionally speaking, but it certainly detracts from the smoothness of the transition, which I think we'd like to preserve if at all possible.
(Assignee)

Comment 3

5 years ago
Comment on attachment 8406382 [details] [diff] [review]
Patch v1

That's an empty patch. *sigh*, qref. Brb.
Attachment #8406382 - Attachment is obsolete: true
Attachment #8406382 - Flags: review?(gijskruitbosch+bugs)
Attachment #8406382 - Flags: review?(MattN+bmo)
(Assignee)

Comment 4

5 years ago
Posted patch Patch v1.1Splinter Review
Here we are.
Attachment #8406389 - Flags: review?(gijskruitbosch+bugs)
Attachment #8406389 - Flags: review?(MattN+bmo)

Comment 5

5 years ago
Comment on attachment 8406389 [details] [diff] [review]
Patch v1.1

Review of attachment 8406389 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me, but let's either trypush or monitor fx-team/m-c carefully as we land this to check CART does OK.
Attachment #8406389 - Flags: review?(gijskruitbosch+bugs)
Attachment #8406389 - Flags: review?(MattN+bmo)
Attachment #8406389 - Flags: review+
(Assignee)

Comment 6

5 years ago
Since we're essentially going back to the same behaviour as before, I'm not too too worried about CART, but I'll keep my eye on it.

Thanks!

remote:   https://hg.mozilla.org/integration/fx-team/rev/bba21dfbd381
Whiteboard: [Australis:P3+] → [Australis:P3+][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/bba21dfbd381
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3+][fixed-in-fx-team] → [Australis:P3+]
Target Milestone: --- → Firefox 31
(Assignee)

Comment 8

5 years ago
Comment on attachment 8406389 [details] [diff] [review]
Patch v1.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

Fallout from a badly selected attribute in a CSS rule from bug 973694.


User impact if declined: 

A rather unpleasant flash of a flat background colour on the titlebar during the middle of the customize mode transition.


Testing completed (on m-c, etc.): 

Local testing.


Risk to taking this patch (and alternatives if risky): 

Extremely low - CSS only, and very much isolated to just the customize mode transition.


String or IDL/UUID changes made by this patch:

None.
Attachment #8406389 - Flags: approval-mozilla-beta?
Attachment #8406389 - Flags: approval-mozilla-aurora?
Comment on attachment 8406389 [details] [diff] [review]
Patch v1.1

Approving because it is a low risk and a tiny patch (and also because Australis matters)
Attachment #8406389 - Flags: approval-mozilla-beta?
Attachment #8406389 - Flags: approval-mozilla-beta+
Attachment #8406389 - Flags: approval-mozilla-aurora?
Attachment #8406389 - Flags: approval-mozilla-aurora+

Comment 11

5 years ago
This was fixed for normal mode, but not for fullscreen mode.

Verified as fixed on Mac OS X 10.9.2 using Firefox 29.0b9 and the 04/17 Aurora and Nightly.
Filed bug 998275 for fullscreen.

Updated

5 years ago
Depends on: 998275
You need to log in before you can comment on or make changes to this bug.