Closed Bug 996264 Opened 6 years ago Closed 6 years ago

[B2G][Gaia]Selecting 'more info' in the geolocation prompt does not expand more information

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S1 (9may)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- fixed

People

(Reporter: astole, Assigned: gasolin)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

Attached file logcat
When the geolocation prompt appears and 'More info' is tapped on, it switches to 'Hide info' but does not expand more information

Repro Steps:
1) Update a Buri to BuildID: 20140414040203
2) Open the Camera app
3)  When prompted, select 'more info'

Actual:
Selecting more info does not bring up any more info

Expected:
Selecting more info expands 

1.5 Environmental Variables:
Device: Buri 1.5 MOZ
BuildID: 20140414040203
Gaia: f3abbd2d0a60f1a1618db93f8b1957cae6de379c
Gecko: 215080b813a7
Version: 31.0a1
Firmware Version: V1.2-device.cfg

Repro frequency: 100%
See attached: Video, logcat
This issue does not occur on the latest v1.4.

Environmental Variables:
Device: Buri 1.4 MOZ RIL
BuildID: 20140414000201
Gaia: 8dff633372022723e2ebad17fe3c826436b3b258
Gecko: bc14179fc49c
Version: 30.0a2
Firmware Version: v1.2-device.cfg
blocking-b2g: --- → 2.0?
Component: Gaia → Gaia::System::Window Mgmt
Plus it for regression.
blocking-b2g: 2.0? → 2.0+
QA Contact: jzimbrick
b2g-Inbound Regression Window:

Last Working Environmental Variables: 
Device: Buri
BuildID: 20140405122225
Gaia: 9c1c36f4676bd8bf2bdda6404c4b003e8595da2b
Gecko: 0c0d70027144
Version: 31.0a1
Base Image: V1.2-device.cfg

First Broken Environmental Variables: 
Device: Buri
BuildID: 20140405225726
Gaia: f1a98bfaa3ab2480945bd7018831fd56c61cdc24
Gecko: df90f6f50617
Version: 31.0a1
Base Image: V1.2-device.cfg

Last Working Gaia / First Broken Gecko: Issue does NOT occur.
Gaia: 9c1c36f4676bd8bf2bdda6404c4b003e8595da2b
Gecko: df90f6f50617

First Broken Gaia / Last Working Gecko: Issue DOES occur.
Gaia: f1a98bfaa3ab2480945bd7018831fd56c61cdc24
Gecko: 0c0d70027144

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/9c1c36f4676bd8bf2bdda6404c4b003e8595da2b...f1a98bfaa3ab2480945bd7018831fd56c61cdc24
Caused by bug 971538.

Fred - Can you take a look?
Blocks: 971538
Flags: needinfo?(gasolin)
I'll check it
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
Flags: needinfo?(gasolin)
It's caused by not correctly rebase the hide-info related commit after refactory. 

fixed and add related test case.
Attachment #8407961 - Flags: review?(alive)
Attachment #8407961 - Flags: review?(alive) → review+
merged https://github.com/mozilla-b2g/gaia/commit/2704f6bbd3f4bfb078decb94e00a2e91ee046436

thanks!
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S1 (9may)
You need to log in before you can comment on or make changes to this bug.