Closed Bug 996372 Opened 7 years ago Closed 7 years ago

selecting a click event to monitor, then clicking in the page crashes Aurora 30 and Beta 29

Categories

(DevTools :: Debugger, defect)

30 Branch
x86
macOS
defect
Not set
normal

Tracking

(firefox29 fixed, firefox30 verified, firefox31 verified)

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- fixed
firefox30 --- verified
firefox31 --- verified

People

(Reporter: karlcow, Assigned: masayuki)

References

()

Details

(Keywords: crash, reproducible)

Crash Data

Steps:
0. Go to http://todomvc.com/vanilla-examples/vanillajs/
1. Start Debugger
2. Select the list of Events (panel on the right, second tab)
3. check the box "click" (html)
4. Go to the html page and click.

What would you like?
Monitoring the event and stop in the debugger as it should.

What is happening?
Aurora is crashing.
I could reproduce this only when there were no todo items in the app (no idea why).

https://crash-stats.mozilla.com/report/index/7c5a7b06-a2a9-4658-bb7f-398d42140415

This looks like bug 964718.
Blocks: 964718
Crash Signature: [@ mozilla::WidgetQueryContentEvent::Duplicate() const ]
Keywords: crash
Beta has it too.
Summary: selecting a click event to monitor, then clicking in the page crashes Aurora 30 → selecting a click event to monitor, then clicking in the page crashes Aurora 30 and Beta 29
Keywords: reproducible
Fixed by uplifting bug 964718 to 29 and 30.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Assignee: nobody → masayuki
No longer blocks: 964718
Depends on: 964718
Target Milestone: --- → Firefox 31
Reproduced on Aurora 2014-04-14.
Verified as fixed on Firefox 30 beta 2 (20140505140302) and latest Aurora 31.0a2 2014-05-05.
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: petruta.rasa
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.