Closed Bug 996531 Opened 7 years ago Closed 7 years ago

[tarako][perf] improve performance of loading Homescreen at startup

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P2)

Other
Gonk (Firefox OS)
defect

Tracking

(b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 999953
1.4 S6 (25apr)
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: angelc04, Unassigned)

Details

(Keywords: perf, Whiteboard: [c=progress p= s=2014.04.25 u=])

Attachments

(1 file)

Step to reproduce
-----------------------------------------------------------------------
1. Go to Settings -> Screen lock
2. Disable Lock Screen
3. Long press power button, and select "Restart"
   --> After device starts, you will notice that it took about 2s for Homescreen to load all icons. According to spreadtrum, they want this time to be limited to 0.5s.


Test build
------------------------------------------------------------------------
Gaia 23488b1a45221c17e6a32fdd4c9d0fdbdcf2d021 
Gecko https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/72055108f470
BuildID 20140414164002
Version 28.1
ro.build.version.incremental=eng.cltbld.20140414.200743
blocking-b2g: --- → 1.3T?
triage: not blocking. to backlog
blocking-b2g: 1.3T? → backlog
Priority: -- → P2
Whiteboard: [c=progress p= s= u=]
spreadtrum need this performance improvement, renfeng and fabrice, help.
blocking-b2g: backlog → 1.3T?
any suggestion for this ?

the performace issue is the same as any other app start up.
Status: NEW → RESOLVED
blocking-b2g: 1.3T? → ---
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 999953
Attached file profile
Captured a profile, brief glance I saw:

  convertAppsArray() @ Webapps.js,
  apps.forEach(function eachApp(app) {...}); @ grid.js:985

Haven't looked into details to understand what is going on.
(In reply to Ting-Yu Chou [:ting] from comment #5)
> Created attachment 8412471 [details]
> profile
> 
> Captured a profile, brief glance I saw:
> 
>   convertAppsArray() @ Webapps.js,

That's a known issue, but won't be fixed in 1.3t.
Component: Performance → Gaia::Homescreen
Whiteboard: [c=progress p= s= u=] → [c=progress p= s=2014.04.25 u=]
Target Milestone: --- → 1.4 S6 (25apr)
You need to log in before you can comment on or make changes to this bug.