Crossover plugin fails to load with undefined symbol: XtDisplayToApplicationContext

VERIFIED INVALID

Status

()

Core
Plug-ins
--
major
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Robin Green, Assigned: av (gone))

Tracking

({relnote})

Trunk
x86
Linux
relnote
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20010914
BuildID:    2001091408

Seems to be a mozilla bug because the Crossover plugins used to work on previous
mozilla builds.

Reproducible: Always
Steps to Reproduce:
1. Install Crossover plugin from codeweavers.com
2. From Crossover plugin setup, install Quicktime plugin
3. Restart mozilla
4. Go to URL above

Actual Results:  Browser crashes with this message on console:

./mozilla-bin: error while loading shared libraries:
/usr/local/mozilla/plugins/npwine.npqtplugin.so: undefined symbol:
XtDisplayToApplicationContext

Expected Results:  load the plugin
(Reporter)

Comment 1

16 years ago
just installed moz0.9.3 and cp'd the plugins over - worked fine. looks like a
moz bug.

Comment 2

16 years ago
Testing with a current CVS mozilla build I watched Quicktime plugin play the
trailer for "Monsters, Inc." No error messages.

Happy to say WFM (I ordered the Crossover CD two days before this bug was filed
and it finally arrived today.)

Comment 3

16 years ago
Also tested on trunk nightly build ID 2001100521: No errors, Quicktime movies
play fine with Crossover plugin. WFM.

The plugins i copied over to /usr/local/mozilla/plugins were:
npwine.npqtplugin.so
npwine.npqtplugin3.so
npwine.npqtplugin2.so
npwine.npqtplugin4.so
npwine.npqtplugin5.so
npwine.NPSWF32.so
npwine.np32dsw.so

Reporter: Are you still seeing the bug as originally reported in the latest
nightlies? (Reply by clicking link to bug near top of bug-mail and use
comment-form on web)
(Reporter)

Comment 4

16 years ago
Still crashing for me with build 200100621

Linux 2.4.10 i686
glibc2.2.2-10
binutils-2.10.91.0.2-3
XFree86-4.1.0-0.0.1

Any suggestions how I could pinpoint the error? Something must have changed
between moz0.9.3 and build 2001091408. Trouble is, mozilla crashes with that
error message without invoking talkback. I could try binary search testing
previous builds to find when it broke - anything else I could try?

Comment 5

16 years ago
Does setting LD_ASSUME_KERNEL=2.2.5 have any effect? Do you see this on a system
with the 2.2 kernel?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

16 years ago
LD_ASSUME_KERNEL=2.2.5 has no effect. I'll try kernel 2.2 later.

Filed bug 103763 for the talkback not being invoked issue.

Comment 7

16 years ago
Assuming you mean 2001091408: yes.
Download the next nightly (but not the currently latest:
There's been a plugin fix you might like lately (the java crasher))

Then try again, and report back?

Comment 8

16 years ago
my own config is

kernel-2.4.2-2
glibc-2.2.2-10
binutils-2.10.91.0.2-3
XFree86-4.0.3-5

Comment 9

16 years ago
This also happens to me upon loading a png image, at URL.  
http://freecnc.sourceforge.net/screenshots/allyourbase.png

Slackware Linux 8.0
Xfree 4.1.0
Moz: 2001101202  0.9.5

Comment 10

16 years ago
Again: works like a dream here. The png files when loaded on a page without
html, are displayed by the Quicktime plugin, if it's set up to deal with .png files.
And again - it works like a dream here.
What happens when you run Quicktime as a free-standing application?

Comment 11

16 years ago
adding pavlov to CC.
XtDisplayToApplicationContext is mentioned in two files:

seamonkey/source/widget/src/xlib/nsAppShell.cpp
seamonkey/source/widget/src/gtkxtbin/gtkxtbin.c

All Crossover plugins run just fine here, in CVS build as well as current
nightly. Only "main" difference between my own and reporter's system is XFree86
version.

Comment 12

16 years ago
This is strange. Suddenly i've started seeing this bug too:
It now always crashes when loading crossover plugins, with 
/usr/local/mozilla/mozilla-bin: relocation error:
/usr/local/mozilla/plugins/npwine.NPSWF32.so: undefined symbol:
XtDisplayToApplicationContext

The build I'm using is 2001102106. I earlyer played a QT video in this same
build just fine - and today: only crahes, also on the same video i played OK
earlyer.

Three days ago i upgraded rh7.1 to errata to kernel 2.4.9 and the new glibc
files. I then built the new nVidia drivers from source, rebooted and am using
the agpgart driver. This worked fine for three days. All plugins ran - till they
suddenly started crashing today.

Deleting cache did not help.
Creating a brand new .mozilla and profile did not help.

I  noticed the appreg file in .mozilla was over 15 times bigger in the old
.mozilla dir than the new which is only 15130 bytes - don't know if that's
significant.
Also, a file "registry" does not seem to be recreated. May have been a leftover
from long ago, my old .mozilla dir was over half a year old.

Comment 13

16 years ago
wow.. and here is something even weirder:
After 10 crashes like this, i checked what was in the plugins dir.
I noticed i hadn't linked in java and the acrobat reader plugin yet, so i did that
ln -s /usr/local/Acrobat4/Browsers/intellinux/nppdf.so /usr/local/mozilla/plugins/
ln -s /usr/local/jre1.3.1/plugin/i386/ns600/libjavaplugin_oji.so
/usr/local/mozilla/plugins/

And after this: NO more crashes! Now all crossover plugins suddenly work again:
Both Quicktime and Schockwave Flash.

Comment 14

16 years ago
I also see this. Right after I copied in my shockwave files into the plugins
dir, i am able to load the crossover fine without any crashes at all.

Comment 15

16 years ago
the problem is that we do not link directly against libXt.  flash does, so it
gets dynamically loaded, before crossover's plugin.  the other solution to this
bug is to LD_PRELOAD libXt.

this isn't something we are going to fix.  it should probably be release noted
though.

Comment 16

16 years ago
I mailed Codeweavers: They will comment here tomorrow. The bug is fixed there.

Comment 17

16 years ago
   This is actually an embarrassing CrossOver bug. The plugin we shipped in
version 1.0 did not link with Xt although it does use it. With Netscape and
older releases of Mozilla this was not apparent because Xt always got loaded in
time. This is no longer the case with the newer releases of Mozilla. Xt may or
may not be loaded when the CrossOver plugin gets loaded, it all depends on which
other plugins got loaded before.
   Of course this will be fixed in the 1.01 version which we hope to release
very soon. But who wants to wait :-) Just send an email to the CrossOver support
mailing list at support@wine.codeweavers.com (or directly to me at
fgouget@codeweavers.com) and I will send the corrected plugin file to you right
away (it's not very big, around 32KB compressed).
   I wish to apologize for all the trouble this caused to everyone.
(Reporter)

Comment 18

16 years ago
ok, not a mozilla bug, marking invalid.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 19

16 years ago
A release note is a good idea. The Crossover plugin is brand new, but the only
one that allows Linux users to watch Quicktime movies for instance. (w/Sorenson
codec) I think many will consider it a "must" by and by. Existance of a fix
should be mentioned. Adding relnote keyword.
Keywords: relnote

Comment 20

16 years ago
spam : marking invalid bugs 'verif'. reopen if u disagree, reporter!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.