Closed Bug 996637 Opened 6 years ago Closed 6 years ago

Huge increase of Mac OS X Flash crashes since 2014-04-08 (with Flash 13.0.0.182)

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect, critical)

x86_64
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: kairo, Unassigned)

References

Details

(Keywords: crash, topcrash-mac, topcrash-plugin)

Crash Data

I was about to open a bug on this ... but you beat me to it :-)

Here's a partial list of old versions of the Flash plugin, which includes their release dates:
http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html
Version: unspecified → 13.x
Severity: normal → critical
OSX 10.7.5., Flash 13.0.0.182

For me also safari crashes (says: "plug-in module failure").  This more seems like on the Adobe side.
Adobe's already acknowledged that it's their bug and is working on a fix:
http://forums.adobe.com/thread/1447282
Crash Signature: [@ F284861780_______ ] [@ F_1466881225_______________ ] [@ F344568511_________________________________________ ] [@ F1898074150_______ ] → [@ F284861780_______ ] [@ F_1466881225_______________ ] [@ F344568511_________________________________________ ] [@ F1898074150_______ ] [@ F_798465467___ ]
Crash Signature: [@ F284861780_______ ] [@ F_1466881225_______________ ] [@ F344568511_________________________________________ ] [@ F1898074150_______ ] [@ F_798465467___ ] → [@ F284861780_______ ] [@ F_1466881225_______________ ] [@ F344568511_________________________________________ ] [@ F1898074150_______ ] [@ F_798465467___ ] [@ F_1782799062_ ] [@ F_1311904859________ ]
I believe that this uptick is related to fallout from a recent compiler change, which exposed an outstanding bug in a system library.  New compiler optimizations caused instructions to be emitted which are unsupported on some Mac hardware shipped between 2006-2008.  This issue affects all browsers using the NPAPI Flash Player plugin.

We will be publishing a Mac-only update shortly to address this issue.  The update will be available via our background update service, so users who have opted-in to updates will be patched automatically.
Thanks everyone.  I hope a patch comes out soon.  The problem mostly occurs when I go to any site that uses Flash, so its easy to duplicate.  I'll wait for the next Flash update.
A patch is on the adobe website.  It works for me.  http://get.adobe.com/flashplayer/

Version 13.0.0.201

I'm on a (plane) MacBook circa 2007 running MacOSX 10.6.8; Processor = 2.16Ghz Intel Core 2 Duo; Memory = 4GB 667MHz DDR2 SDRAM.
Confirmed fixed with Flash Player 13.0.0.201.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 996546
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 13.x → unspecified
You need to log in before you can comment on or make changes to this bug.