All users were logged out of Bugzilla on October 13th, 2018

Conn: Cannot access "local" servers

VERIFIED INVALID

Status

()

--
minor
VERIFIED INVALID
17 years ago
16 years ago

People

(Reporter: antti.hartikainen, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When trying to access HTTP or FTP server located on local machine (using
internet-address), mozilla says "the connection was refused when attepting to
contact myaddress.com".

It works with other browser (not netscape6.1), and mozilla 0.9.3 on windows from
the same network, using the that HTTP/FTP-server as "router". Packets goes
through the internet.

Comment 1

17 years ago
Antti, can you post 
  a) your Build ID? (in the title bar)
  b) any proxy configuration you may have.

thanks
(Reporter)

Comment 2

17 years ago
Build ID is 2001080104
No proxies in use.
Antti, could you please test this with a recent build (eg the just-released
0.9.4)?  The build you have is very old....
(Reporter)

Comment 4

17 years ago
Now using build 2001091311, still getting those connection refused notes, any
else (as in old build) server seems to work fine.

Used tcp-connection logger, Mozilla does not even send HTTP-request to server!

And as i said in first post, this works in other browsers, i.e. netscape4.x and
lynx tested.

Comment 5

17 years ago
Antti, are you using IPv6 ? If so, this is a dupe of bug 86229.

Comment 6

17 years ago
Please provide more literal descriptons:

I think you are saying:

My ip address is 1.2.3.4.

I typed: "http://1.2.3.4/" and I got "the connection was refused."

After we get a clearer description, I'm sure everything else can be explained. 

Comment 7

17 years ago
Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Never received more info. Closing as INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID

Comment 10

16 years ago
VERIFIED/invalid

A couple comments: there are some problems when you use localhost. We never find
out what the user was typing.

If you are using a packet tracer, rather than a network stack diagnostic, you
won't see connections to yourself, because the data transfer never goes out on
the wire.
Status: RESOLVED → VERIFIED
Summary: Cannot access "local" servers → Conn: Cannot access "local" servers
You need to log in before you can comment on or make changes to this bug.