[MW] Mousewheel scrolling scrolls page, not Select

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: alex, Unassigned)

Tracking

({helpwanted})

Trunk
x86
Windows 2000
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20010914
BuildID:    2001091403

Using the mousewheel over a SELECT MULTIPLE, Mozilla scrolls the page first, and
only once the page hits bottom does the SELECT scroll.

Reproducible: Always
Steps to Reproduce:
1. Goto the url: http://www.dice.com/jobsearch/
2. Position the mouse over the "Restrict by State" SELECT MULTIPLE
3. Spin the mousewheel

Actual Results:  Page scrolls, and only once the page hits bottom does the
SELECT scroll.

Expected Results:  Page scrolling unchanged, SELECT scrolls.

Interestingly, Bug 33732 is almost the exact opposite of this one. Also,
searched for dupes but the only bugs even close are bug 62905 and bug 62910 (no
match, though). Boris Zbarsky couldn't find any dupes either.

Assigning to bryner at recommendation of BZ.

Comment 1

17 years ago
My recent nightly (2001091303) shows different behavior on Windows ME.
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.4) Gecko/20010913

The first click of the wheel scrolls both the page and the select box.
Then when I continue moving the wheel, it scrolls only the select box
until I use the wheel to scroll the page at least once, after which
the next click of the wheel goes to both the page and the box.

I can also reproduce this behavior on the CC: box in bug 4302.
If it matters, I have the scroll distance set to 8 lines per click (in
Edit > Preferences > Advanced > Mouse Wheel), and I routinely browse with
a 720x480 pixel window on a 1024x768 pixel display.

I have attached a test case.

Comment 2

17 years ago
Created attachment 49410 [details]
A basic test case for the bug

Comment 3

17 years ago
I noticed something different on win2000 - buildID: 2001-09-17-05-0.9.4

1) When the page is loaded ( the page has the focus), spin the mouse wheel.
actual:-
the 'Restrict by state' select box is scrolled  up/down.
expected:-
the page should scroll up/down - not the select box

2) Now try doing the the PgUp/PgDown or up/down arrows from the keyboard.
actual:-
the page is scrolled up and down as expected.

the mouse scroll wheel and the keyboard navigation keys are acting on different 
controls all together.

Comment 4

17 years ago
I see the same behaviour on http://bugzilla.mozilla.org/query.cgi
The 'OpSys' select box starts scrolling up and down using the mouse wheel, when 
the page is loaded.

Comment 5

17 years ago
This bug looks like a dup of bug 33732.
Madhur: Actually, bug 33732 is just the opposite of this bug. 

Damian: Regarding your testcase (attachment 49410 [details]), here's what happens for me
if I position my cursor over the SELECT and spin the wheel: the page scrolls
down until it hits bottom, then the SELECT scrolls.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.6
Keywords: helpwanted
Target Milestone: mozilla0.9.6 → mozilla0.9.9

Comment 7

17 years ago
This looks fixed to me ... I click on the select and then scroll and it works ...
John: Try doing it without clicking on the select first. Then, you should see
the effect described. (fwiw, still occurs for me on 2001111403 on Win2k)
Depends on: 112713
XBL form controls will not be turned on for 0.9.9.  -> 1.0.
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 10

17 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2
*** Bug 130927 has been marked as a duplicate of this bug. ***
Assignee: bryner → nobody
Status: ASSIGNED → NEW
QA Contact: madhur → layout.form-controls
Target Milestone: mozilla1.2alpha → ---
This should be WFM now.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.