Closed Bug 996725 Opened 8 years ago Closed 8 years ago

Apps launch to a white screen when installed via Marketplace reviewer interface

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect)

30 Branch
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 889744

People

(Reporter: eviljeff, Unassigned)

Details

When I install an app via the Marketplace Reviewer tools it appears to install correctly (icon, permissions dialog, etc) but when I launch the app itself its only a white blank page.

This is with Firefox for Android Aurora (30).  I also have Beta installed, and each time I am prompted if I want to run the app in Beta or Aurora - I choose Aurora, which is where the app was installed from.

This appears to happen to any packaged app - if I install kitchen sink, for example, from the consumer page [1] it works; from the review page [2] I get a white app.

[1] https://marketplace.firefox.com/app/kitchensink
[2] https://marketplace.firefox.com/reviewers/apps/review/kitchensink
Bug 989294 describes the same issue, and has been fixed on Aurora30.0a2(2014-04-15), can you check again please with the latest Aurora build, and see if this is still reproducible?
(In reply to Mihai Pop from comment #1)
> Bug 989294 describes the same issue, and has been fixed on
> Aurora30.0a2(2014-04-15), can you check again please with the latest Aurora
> build, and see if this is still reproducible?

still reproducible for 2014-04-16 (hosted apps seem to work, just not packaged apps).
we think this has the same underlying cause as 889744, resolving as duplicate
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 889744
(In reply to Bill Walker [:bwalker] [@wfwalker] from comment #3)
> we think this has the same underlying cause as 889744, resolving as duplicate

I'm not saying the thought is incorrect, but why?  And are there any logs, etc, I can provide to confirm/deny?
(In reply to Andrew Williamson [:eviljeff] from comment #4)
> (In reply to Bill Walker [:bwalker] [@wfwalker] from comment #3)
> > we think this has the same underlying cause as 889744, resolving as duplicate
> 
> I'm not saying the thought is incorrect, but why?

Bug 889744 was about support for installing packaged apps from reviewer pages generally.  Until it was resolved, the behavior we expected is exactly what you describe: the install appears to succeed, but launching the app results in it hanging with a white screen.  That's why we thought this bug is a duplicate of that one.

> And are there any logs, etc, I can provide to confirm/deny?

The failure doesn't generate interesting logs, but now that bug 889744 has been resolved, you can try testing with the latest nightly build of Fennec to see if the problem is still happening!  Note that you need to use about:config to create the boolean pref dom.mozApps.use_reviewer_certs and set it to true in order to use the functionality that was implemented to fix the bug.
I've just tried with the latest Nightly (2014-05-01) and still get a white screen for reviewer installed apps.  I created the pref as specified.
Has QA/someone confirmed this actually works?  Specifically with other versions of Firefox installed too (i.e. I have Beta and Aurora, in addition to Nightly, installed).
Flags: needinfo?(myk)
I can't tell from bug 889744 wether the checkin on inbound was ever merged to central.
Bug 889744 was fixed by blocking bug 989806, which merged to central on Tuesday, April 29 at 20:39:44 UTC, according to the push log <https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=8234dac0ea59>.

The change was not uplifted to the Aurora/Beta branches, so builds from those branches will still exhibit the bug.  But Nightly should work, even if Aurora/Beta builds are also installed.

There may be other bugs with the same symptom, however.  For example, bug 1003962 is about the Line Runner app hanging on launch with a white screen. And bug 991394 is about apps exhibiting the same symptom after originally working.  Many bugs can cause that symptom, so you might be running into a different one.

That being said, it's of course also possible that we didn't fix bug 889744 like we thought we did.  If you point me at some apps in the queue that exhibit the problem, then I'll reproduce it on my test devices!
Flags: needinfo?(myk)
(In reply to Myk Melez [:myk] [@mykmelez] from comment #8)
> That being said, it's of course also possible that we didn't fix bug 889744
> like we thought we did.  If you point me at some apps in the queue that
> exhibit the problem, then I'll reproduce it on my test devices!

https://marketplace.firefox.com/reviewers/apps/review/kitchensink
launches to a white screen for me

works fine when installed via public page:
https://marketplace.firefox.com/app/kitchensink/
(In reply to Andrew Williamson [:eviljeff] from comment #9)
> https://marketplace.firefox.com/reviewers/apps/review/kitchensink
> launches to a white screen for me

Hmm, I'm unable to reproduce this problem.  I went to this page in today's Nightly build, tapped the Install button, confirmed the installation when prompted, and then launched the app.  Android prompted me to pick a runtime, as I have multiple installed, and I told it to use Nightly.  The app then ran as expected.

So I'm not sure why you're getting a hang.  Perhaps you've run into another bug, like bug 991394.  You might try uninstalling and reinstalling KitchenSink, uninstalling and reinstalling Nightly, or capturing logcat from this build that was compiled with extra logging:

  https://people.mozilla.org/~myk/synthapk/fennec-32.0a1.en-US.android-arm.apk
It works!  I can't say what the issue before was but I can now install with the latest Nightly.
I don't know if this adds to the conversation, but here it goes:
I've been having trouble installing apps from the marketplace too. I was algo getting the blank screen bug. After some hours trying to install packaged apps for android from the reviewers queue on marketplace, I finally succeeded. 

What I did to solve the problem was this:
- Clear the app data for Firefox, Firefox Beta and Firefox Aurora. To do this on Android, go to Settings -> Apps, select the app (Firefox, Firefox Beta or Firefox Aurora) and click on the "Clear data" button. Do this step for all the Firefox distributions you have installed.
- Uninstall all the Firefox apps: Firefox, Firefox Beta and Firefox Aurora.
- Close all the open apps on your android device.
- Turn off the phone. 
- Remove the SD card (in case you use an SD card on your phone). 
- Format the SD card (FAT should be the chosen format).
- Put back the SD card and turn on the phone.
- Install Firefox Aurora: open a web browser on your android device, search for "firefox aurora android" and probably the first search result will get you to the download page.
- Open Firefox Aurora, go to about:config, create the boolean pref dom.mozApps.use_reviewer_certs and set it to true.
- Go to the marketplace website and try to install a packaged app from the reviewers queue.

Expected result: The packaged apps for Android should be installed OK and the blank screen should not appear anymore.

I'm not sure if some of these steps can be ignored, but at least that's how I got rid of the blank screen bug on my android device.
I was using a Samsung Galaxy S with Android 4.2.2.
(In reply to mario from comment #12)
> - Install Firefox Aurora: open a web browser on your android device, search
> for "firefox aurora android" and probably the first search result will get
> you to the download page.
> - Open Firefox Aurora, go to about:config, create the boolean pref
> dom.mozApps.use_reviewer_certs and set it to true.
> - Go to the marketplace website and try to install a packaged app from the

You only needed those last few steps Mario :)  Sorry, I updated the guide[1] after the patch was uplifted to Aurora last week and have an email written in drafts to send out to all reviewers but we had to decide whether to wait for it to hit Beta in a few weeks or tell everyone to use Aurora now.

[1] https://wiki.mozilla.org/Marketplace/Reviewers/Apps/Guide/Setup
Yep Andrew, we would probably need only the last few steps (in an ideal scenario). 
But in my case I had Firefox Beta previously installed, and the blank screen bug was appearing (on both browsers) while I had both of Firefox Beta and Firefox Aurora installed.

That's why I did a "delete all browsers, format SD card, restart phone, install Fx Aurora" procedure. Maybe someone else is facing the same trouble as me and I hope this could help :) .
(In reply to mario from comment #14)
> Yep Andrew, we would probably need only the last few steps (in an ideal
> scenario). 

You really do only need the last few steps.  

> But in my case I had Firefox Beta previously installed, and the blank screen
> bug was appearing (on both browsers) while I had both of Firefox Beta and
> Firefox Aurora installed.

yes, the patch only hit Aurora a few days ago, its not in Beta yet.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.