Closed Bug 996755 Opened 9 years ago Closed 8 years ago

[B2G][MMS] Unsupported data formats are not displayed corrected when received by MMS

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.3 affected, b2g-v1.3T affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
2.1 S7 (24Oct)
Tracking Status
b2g-v1.3 --- affected
b2g-v1.3T --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: rkunkel, Assigned: steveck)

References

Details

(Whiteboard: 1.3tarakorun2 [2.1-flame-test-run-1][p=1])

Attachments

(6 files)

Attached file logcat
Description:
When the user receives an MMS with an unsupported data format, the format is either not displayed or displayed improperly. 

Repro Steps:
1) Update a Tarako device to v1.3T BuildID: 20140414004001
2) Open email on desktop
3) Create and email with an attachment of an unsupported data format (.pdf or .doc)
4) Send the email with the attachment to the device by using <device_number>@mms.att.net for the "To" field
5) Open the MMS on the device

Actual:
The device does not display unsupported data formats 

Expected:
The device will show unsupported data formats as unknown file type

v1.3T Environmental Variables:
Device: Tarako v1.3T MOZ
BuildID: 20140414004001
Gaia: 0e7f21e61625b75a9149480cd5a259211549f020
Gecko: 3b02811c314a
Version: 28.1
Firmware Version: sp6821

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/7826/
See attached: logcat, firewatch, screenshot
Attached file firewatch
Attached image screenshot
This issue DOES reproduce on the latest v1.3 Buri build:

v1.3 Environmental Variables:
Device: Buri 1.3 MOZ RIL
BuildID: 20140414004002
Gaia: 8b92c56267fe50772095f1f25d6cc1f9c9966eb4
Gecko: 3e26908fca71
Version: 28.0
Firmware Version: V1.2-device.cfg
At the least I think it's not a regression because we didn't do it in 1.1.

Still it's supposed to work :(
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: 1.3tarakorun2 → 1.3tarakorun2 [2.1-flame-test-run-1]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
QA: can you please check on current master?
Thanks !
Keywords: qawanted
Issue DOES occur in the latest Flame Master build (v180) KK base.

Actual Results: 
MMS is received, but the attachment is not listed nor is it shown as an unknown file. 

Device: Flame Master
Build ID: 20141003132548
Gaia: 83f495a1c12687970f7f2840c2729795c4b88177
Gecko: 229801d17f7e
Version: 35.0a1 (Master)
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Contact: ddixon
Issue DOES occur in the latest Flame Master build (v180) KK base.

Actual Results: 
MMS is received, but the attachment is not listed nor is it shown as an unknown file. 

Device: Flame Master
Build ID: 20141003132548
Gaia: 83f495a1c12687970f7f2840c2729795c4b88177
Gecko: 229801d17f7e
Version: 35.0a1 (Master)
Firmware Version: L1TC10011800
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage][lead-review+]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage][lead-review+] → [QAnalyst-Triage?][lead-review+]
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(jmitchell)
Hi Duane, I found a possible bug that mms smil didn't contained all the attachments, especially when file format is not supported. But I'm not sure if it's same root cause(I sent mms from other Android phone, not email). If you could still reproduce this issue after patch applied, please provide your database by pulling the data from phone(adb pull /data/local/storage/persistent/), thanks!
Attachment #8500836 - Flags: feedback?(ddixon)
Steve, 

Sorry, but we don't have the resources to apply the patch you have listed in Comment 8.
Attachment #8500836 - Flags: feedback?(ddixon)
Duane, can you please share the SMS db that exhibits this issue?

You can run this command:

  adb shell pull /data/local/storage/persistent/chrome/

And then zip the result (the "idb" directory) and attach it here. Zipping only the files and directory containing "ssm" should be enough. If you have personal information in your SMS database, maybe share it privately by mail to Steve and I.

Thanks !
Assignee: nobody → schung
Flags: needinfo?(ddixon)
Whiteboard: 1.3tarakorun2 [2.1-flame-test-run-1] → 1.3tarakorun2 [2.1-flame-test-run-1][p=1]
Target Milestone: --- → 2.1 S7 (24Oct)
Flags: needinfo?(ddixon)
Duane, sorry, but you miss the directory that has the same name as well. This is where the attachments are stored so we need it :)
Thanks a lot
Flags: needinfo?(ddixon)
I'm not sure what I failed to attach that you need, so I will just upload the whole zip file for you.  Hope that works.
Flags: needinfo?(ddixon)
Attached file idb_full.zip
Hey Duane,

I don't think this db contains the MMS that has the issue reported here...

Or... the attachment has not been received at all, which would explain the issue you see.

Can you confirm it works for other devices? 
If yes we may have an issue in the RIL.
Flags: needinfo?(ddixon)
Issue DOES occur in Buri Master, Open_C 2.2, and Flame 2.0 base image.  

Actual Results: Unknown files (such as: .docx, .doc) sent from an email address to the phone are not displayed in the MMS. 

Device: Buri Master
Build ID: 20141016040204
Gaia: 841d0d7d1b879f0ff4b5a8727f5dd23c7b0000a9
Gecko: a280a03c9f3c
Version: 36.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-------------------------------------------------------------------------------
Device: Open_C Master
Build ID: 20141003070740
Gaia: a8a6eed2ba9d66239aac789b9ee4900f911c73cb
Gecko: 388e101e75c8
Version: 35.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Flags: needinfo?(ddixon)
Can you please try on non-Firefox OS devices? Eg Android or iPhone?
Flags: needinfo?(ddixon)
Android Device (Verizon Wireless as the carrier). 
Results: Message is received and reads: "Attachments Removed"

iPhone Device (Verizon Wireless as the carrier). 
Results: Message is received and reads: "Attachments Removed"

iPhone Device (At&t Wireless as the carrier). 
Results: Message is received and does not show any attachments or unknown files. 

LG device (Metro PCS as the carrier). 
Results: Message is received and notifies the user that there is an unknown file attached.
Flags: needinfo?(ddixon)
Duane, can you confirm which carrier you used to test the Firefox OS device earlier? If this is AT&T, then we behave the same than iPhone, so I think it's a carrier issue.

Maybe you can try with the various SIM you used in comment 18, to see if something different happens.

Thanks a lot, this is very helpful!
Flags: needinfo?(ddixon)
Yes, our test devices are equipped with At&t SIM cards by default. 

I tested one more variant with a T Mobile SIM card. 
Results: Text message is received and reads "Attachment can be downloaded until [date].  Downloading..." 

In conclusion, the user is notified that there is a file to be viewed, but the device fails to download it.  I agree, the results appear to be dependent on the the carrier.
Flags: needinfo?(ddixon)
It would be useful to have the full log following https://github.com/bevis-tseng/Debug_Tools when you try using T-Mobile (from receiving to downloading).
See Also: → 1090043
Hi Duane, since bug 1090043 landed in master, could you please verify this issue again? thanks!
Flags: needinfo?(ddixon)
I am unsure if this issue can be verified as fixed due to the mixed test results I've collected. Again, this issue seems to depend on what wireless carrier is being used.  If my results listed below appear correct, please let me know and I will verify this bug.  Thanks. 

At&t SIM card: 

Flame 2.2, 2.1: User is NOT notified of an unreadable text attachment. 

T Mobile SIM card: 

Flame 2.2: User is notified about an unreadable text attachment and provides a window for the user to access which leads to an "unable to open an attachment" screen. 

Flame 2.1: User is notified about an unreadable text, but is NOT provided an accessible window. 


Device: Flame 2.2
BuildID: 20141103040202
Gaia: bc168c17474dabbcceaa349e9bc7c95654435aec
Gecko: 5999e92e89ff
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1
BuildID: 20141103001220
Gaia: 027a7de0c95320cea0579bfd1a4ceef3e9038f34
Gecko: ffecb2be228b
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(ddixon)
(In reply to Duane Dixon [:ddixon] from comment #23)
> I am unsure if this issue can be verified as fixed due to the mixed test
> results I've collected. Again, this issue seems to depend on what wireless
> carrier is being used.  If my results listed below appear correct, please
> let me know and I will verify this bug.  Thanks. 
> 
> At&t SIM card: 
> 
> Flame 2.2, 2.1: User is NOT notified of an unreadable text attachment. 
> 
> T Mobile SIM card: 
> 
> Flame 2.2: User is notified about an unreadable text attachment and provides
> a window for the user to access which leads to an "unable to open an
> attachment" screen. 
> 
> Flame 2.1: User is notified about an unreadable text, but is NOT provided an
> accessible window. 
> 
Based on the description for T Moblie, I think the patch for bug 1090043 still has some effect that provides the "unable to open" window. But for At&t, it's very likely they didn't send the attachment to user(like you said in comment 18 for iphone case). I'll close this one since we could do nothing if there is no attachment. Please reopen if you could verify Android with At&t carrier could display the attachment correctly, thanks.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.