Freeze up when launching NetRadio players

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
P2
critical
RESOLVED INVALID
17 years ago
7 years ago

People

(Reporter: Rick Stevens, Assigned: Louie Zhao)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: confirm, URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080104

When launching either NetRadio player (simple or advanced), Mozilla freezes up
completely.  If the application is killed via X, a "ps -ax"
reveals a bunch of mozilla-bin threads are still running:

10745 ?        S      0:00 /bin/sh /usr/local/mozilla/run-mozilla.sh
/usr/local/10753 ?        S      4:57 /usr/local/mozilla/mozilla-bin
10755 ?        S      0:00 /usr/local/mozilla/mozilla-bin
10756 ?        S      0:00 /usr/local/mozilla/mozilla-bin
10757 ?        S      0:00 /usr/local/mozilla/mozilla-bin
10762 ?        S      0:01 /usr/local/mozilla/mozilla-bin
12208 ?        S      0:00 /usr/local/mozilla/mozilla-bin
12233 ?        S      0:00 /usr/local/mozilla/mozilla-bin

These have to be killed also before Mozilla runs stabily (sp?) again.

Reproducible: Always
Steps to Reproduce:
1.Set up an account at NetRadio
2.Select a player
3.Select a music genre
4.Launch the player

Actual Results:  Freeze up.  Dragging the window causes leftovers.  Windows can't be
closed.  No widgets in the titlebars work.  You must kill ALL instances of
mozilla-bin to get it to work again.

Expected Results:  Played the music through the audio player.

This browser also has a tendency to lock up randomly--aparently when
heavily Javascripted pages are displayed.
(Reporter)

Comment 2

17 years ago
I don't think it's a duplicate, as I don't think flash is involved and /dev/dsp
is not active on my system when this occurs.

Comment 3

17 years ago
can you try with 0.9.4?
(Reporter)

Comment 4

17 years ago
0.9.4 displays the same behaviour.  It appears to be a java_vm issue.

Comment 5

17 years ago
Why do you think this is Java releated? It looks like the player uses either the
realplayer plugin or the windows media player plugin
Assignee: asa → av
Component: Browser-General → Plug-ins
QA Contact: doronr → shrir
(Reporter)

Comment 6

17 years ago
I agree that the audio portion uses RealPlayer or WM, however the website itself
seems to use Java and seems to lock up the browser before a full handoff to the
player is completed.  During the last lockup I checked, I noticed a number of
java_vm processes that appear to be stalled.  I've found similar lockups when
viewing some other sites such as www.ibm.com (I think that was one).
(Reporter)

Comment 7

17 years ago
More information on this problem.  It's Java-related.  If I open the Java
console from the Tasks->Tools menu, the lockup occurs.  Same thing if I run
Debug->Verification->Javascript.

Could this be a bad Javascript thing I have installed?  I have jdk 1.2.2, jdk
1.3, and jre 1.3.1 installed in /usr/local.

System info:
RedHat Linux 7.1, current patches (as of 9/10/01)
kernel 2.4.7
Pentium III/900MHz
512MB RAM
20GB hard disk.

Comment 8

17 years ago
I think this may be a dup of bug 84093.

Can you install a newer build of Mozilla? If you are using the JRE 1.3.0 plugin
under RH 7.1 with the 2.4 kernel, you may need to set the environment variable
LD_ASSUME_KERNEL=2.2.5. jre 1.3.1 should work correctly but it's not the default
install (yet).


Assignee: av → edburns
Status: UNCONFIRMED → NEW
Component: Plug-ins → OJI
Ever confirmed: true
QA Contact: shrir → pmac
(Reporter)

Comment 9

17 years ago
The build I'm running is 0.9.4, build ID 2001091311.  I'm not certain how to
tell Mozilla which JRE to run.  As I said, I have jre 1.3.1 in /usr/local/jre1.3.1.
Can you give me a hint as to what to set?  And is there a fairly complete
user's/administrator's guide available?  Inquiring minds want to know!

Comment 10

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: edburns → petersen
(Reporter)

Comment 11

16 years ago
Since NetRadio is now defunct, I guess this bug is superflous.  However, a
similar glitch occurs with Spinner.  The graphics for their player are somewhat
hosed and many of the options don't work.

I'm trying this under Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1)
Gecko/20020826.  If you go to this URL:

http://spinner.com/floor.jhtml?url=%2Fcharts%2F_main.jhtml&stationid=71

and click on the "Listen" button, you'll see what I mean.

System: RedHat 7.1 with all current patches, kernel 2.4.18 (from kernel.org source).
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Comment 13

15 years ago
reassign to me
Assignee: joe.chou → joshua.xia

Comment 14

15 years ago
Confirm on Linux(RH8.0) mozilla1.2.1 JRE1.4.1_01
And I found mozilla will exit when click "Listen" in comment 11
Priority: -- → P2
Whiteboard: confirm

Comment 15

15 years ago
add crash since mozilla will exit
Keywords: crash

Comment 16

15 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: major → critical

Comment 17

15 years ago
->louie
Assignee: joshua.xia → Louie.Zhao

Comment 18

14 years ago
With NetRadio gone and spinner gone, do we even have a testcase here? Does the
Radio@netscape thing cover this bug now?
Since there is no testcase and NetRadio now blocks Moz browsers (keeping them
from crashing if this is indeed the case), this bug is no longer valid.

Asa, radio.netscape.com uses a downloadable exe file from what I can tell and is
not valid with this bug.

Resolving as INVALID. Please reopen if you still see the crash.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.