Intermittent bug970643.js | Script runs for too long, terminating. (code 0, args "--ion-eager --ion-parallel-compile=off --ion-check-range-analysis --no-sse3")

RESOLVED FIXED in Firefox 31

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Trunk
mozilla31
x86
Windows 8
Points:
---

Firefox Tracking Flags

(firefox29 unaffected, firefox30 unaffected, firefox31 fixed, firefox-esr24 unaffected)

Details

Attachments

(1 attachment)

https://tbpl.mozilla.org/php/getParsedLog.php?id=37887354&tree=Mozilla-Inbound

WINNT 6.2 mozilla-inbound opt test jittest on 2014-04-15 18:34:38 PDT for push ebcacae1532c
slave: t-w864-ix-081

18:45:11     INFO -  FAIL - basic\bug970643.js
18:45:11  WARNING -  TEST-UNEXPECTED-FAIL | tests\jit-test\jit-test\tests\basic\bug970643.js | Script runs for too long, terminating. (code 0, args "--ion-eager --ion-parallel-compile=off --ion-check-range-analysis --no-sse3")
18:45:11     INFO -  INFO exit-status     : 0
18:45:11     INFO -  INFO timed-out       : False
18:45:11     INFO -  INFO stderr         2> Script runs for too long, terminating.
18:45:11     INFO -  INFO stderr         2> Script runs for too long, terminating.
18:45:11     INFO -  INFO stderr         2> Script runs for too long, terminating.
My money is that this bug and bug 999915 are symptoms of bug 899697.
This looks like the same bug as bug 899697, which you also reviewed, Terrence.
Also I'm real tired of your shit, Windows.
Attachment #8410765 - Flags: review?(terrence)
Comment on attachment 8410765 [details] [diff] [review]
Always allow exit code 0 when checking for exit codes in Windows, because Windows.

Review of attachment 8410765 [details] [diff] [review]:
-----------------------------------------------------------------

Seriously! r=me
Attachment #8410765 - Flags: review?(terrence) → review+
Duplicate of this bug: 999915
https://hg.mozilla.org/mozilla-central/rev/2084e0ea923c
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
You need to log in before you can comment on or make changes to this bug.