Closed Bug 997055 Opened 6 years ago Closed 6 years ago

The same feed is added in multiple panels in the home page

Categories

(Firefox for Android :: General, defect, P1)

31 Branch
ARM
Android
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: TeoVermesan, Assigned: Margaret)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image Home Feeds Add-on
Steps to reproduce:
1. Install https://addons.mozilla.org/en-US/android/addon/home-page-feeds/
2. Go to quality.mozilla.org
3. Tap the add-on's icon to add a feed
4. Choose for example the category: QMO-quality.mozilla.org  News&Events
5. Select "Subscribe with: Firefox homepage"
6. Repeat step 4&5 a few times.

Expected results:
- There should be only one panel displayed for each category.

Actual results
- There are several panels displayed when adding the same feed.
Please see attached screenshot.
Blocks: lists, 977200
Component: Add-on Manager → General
I would say that this is the user's fault, since they chose to add the feed mutliple times, but we could add a check to see if that feed url already exists in the set of stored panels, then show a toast that says something like "Panel already exists" when the users tries to re-subscribe.
Ian, do you think we should update the home feeds add-on to deal with this?

I'm also not sure if we should track this in a bug, or through some other mechanism, since this isn't an issue with Fennec, but rather an issue with the add-on.
Assignee: nobody → margaret.leibovic
Flags: needinfo?(ibarlow)
Priority: -- → P1
Setting P1 hub bugs to block hub v1 EPIC bug (targeting fx30 release).

Filter on epic-hub-bugs.
Blocks: 1014025
(In reply to :Margaret Leibovic from comment #2)
> Ian, do you think we should update the home feeds add-on to deal with this?

Yeah, it would be nice I think. Some kind of toast or dialog that reads "This feed is already on your homepage" or something
Flags: needinfo?(ibarlow)
If I add this feature to the add-on, it will add a new string. Just FYI to pascalc, who's been helping with the localization effort.
(In reply to :Margaret Leibovic from comment #6)
> Fixed:

> Available in version 0.8:
> https://addons.mozilla.org/en-US/firefox/addon/home-feeds/versions/?page=1#version-0.8

Device: LG Nexus 4 (Android 4.4.2)
Builds: all branches
When trying to add the same feed more than once, the notification appears:"This feed is already on your homepage" and only one panel is displayed on about:home
So, I will mark the bug as verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.