Bing search is not present in the default search engines

VERIFIED FIXED in Firefox 29

Status

()

defect
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: cos_flaviu, Assigned: mconnor)

Tracking

({regression})

Trunk
Firefox 31
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28 unaffected, firefox29 verified, firefox30 verified, firefox31 verified, fennec29+)

Details

Attachments

(1 attachment)

Reporter

Description

5 years ago
Environment: 
Device: Google Nexus 7 (Android 4.4.2);
Build: Nightly 31.0a1 (2014-04-16);

Steps to reproduce:
1. Go to settings -> Customize -> Search;
2. Check if Bing search is available.

Expected result:
Bing search is available.

Actual result:
Bing search is not present in the default search engines.
Usually with bugs like these we'll want to make sure we identify and track them as highly visible regressions.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5405d6f4e3c6&tochange=8883360b1edb
Blocks: 984530
tracking-fennec: --- → ?
Keywords: regression
In an affected build, I do see the bing.xml is packaged (e.g, in en-US)

$ ls -al omni.ja/assets/chrome/en-US/locale/en-US/browser/searchplugins/
-rw-rw-r--   1 AaronMT  staff  2860  1 Jan  2010 bing.xml
Assignee

Comment 3

5 years ago
http://mxr.mozilla.org/mozilla-central/source/toolkit/components/search/nsSearchService.js#1946 means the Bing plugin will get discarded.  Yay.

Taking.
Assignee: nobody → mconnor
Status: NEW → ASSIGNED
Assignee

Comment 4

5 years ago
Posted patch bingFixSplinter Review
Pretty straightforward.  Added a comment for clarity.
Attachment #8407552 - Flags: review?(mark.finkle)
Attachment #8407552 - Flags: review?(mark.finkle) → review+
Flipping these since I just saw uplift in bug 984530.
Assignee

Comment 7

5 years ago
Comment on attachment 8407552 [details] [diff] [review]
bingFix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 984530
User impact if declined: no bing search
Testing completed (on m-c, etc.): verified fixed on inbound builds
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none

Also will be requesting for bug 997402.  This stuff needs more automated testing (tracking under Bug 997485) but I'll work with QA to verify manually ASAP
Attachment #8407552 - Flags: approval-mozilla-beta?
Attachment #8407552 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/58b82c1143fb
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Attachment #8407552 - Flags: approval-mozilla-beta?
Attachment #8407552 - Flags: approval-mozilla-beta+
Attachment #8407552 - Flags: approval-mozilla-aurora?
Attachment #8407552 - Flags: approval-mozilla-aurora+
Reporter

Comment 9

5 years ago
Verified as fixed in build 31.0a1 (2014-04-17);
Device: Google Nexus 7 (Android 4.4.2).
tracking-fennec: ? → 29+
Reporter

Comment 11

5 years ago
Verified as fixed in build 30.0a2 (2014-04-18);
Device: Lenovo Yoga Tab 10 (Android 4.2.2).

Will mark the bug as verified after retesting the bug on beta 10.
Reporter

Comment 12

5 years ago
Verified as fixed in build 29 beta 10.
Device: Google Nexus 7 (Android 4.4.2).
Status: RESOLVED → VERIFIED
Seems like mobile could use a variant of the desktop browser_google|bing_behavior.js tests?
Assignee

Comment 14

5 years ago
Yep, tracking test coverage under bug 997485, focusing on desktop first.
You need to log in before you can comment on or make changes to this bug.