Closed Bug 997287 Opened 6 years ago Closed 6 years ago

crash in mozilla::layers::AsyncPanZoomController::OnTouchEndOrCancel()

Categories

(Core :: Panning and Zooming, defect, critical)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla31
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- fixed

People

(Reporter: bzumwalt, Assigned: botond)

References

()

Details

(Keywords: crash, regression, reproducible)

Crash Data

Attachments

(2 files)

Attached file Logcat
This bug was filed from the Socorro interface and is 
report bp-62887e12-5279-4aa5-a91c-fbab42140416.
=============================================================
Description:
Repeatedly tapping done while on Crop page while attaching a picture to an MMS causes phone to crash. Picture chosen must be one that has been taken by device. This seems to reproduce more often in an existing MMS thread rather than a new thread.

This has also occurred when accessing debug menu in email app.

Repro Steps:
1) Updated Buri to BuildID: 20140416040204
2) Launch Messages app
3) Enter existing MMS thread
4) Select paperclip icon to add attachment and chose Gallery
5) Choose image taken from device (not image saved from other source or screenshot)
6) On crop page rapidly press "Done" button and keep pressing in that area after crop page disappears

Actual:
Phone crashes when user rapidly presses done button

Expected:
Phone does not crash when attaching image to MMS

Environmental Variables:
Device: Buri Master M-C Mozilla RIL
BuildID: 20140416040204
Gaia: 3d4b4b06475d2376bad23ac46da185cd48a68d17
Gecko: dd50745d7f35
Version: 31.0a1
Firmware Version: v1.2-device.cfg

Notes:
Repro frequency: 4/5, 90%
See attached: Youtube video clip & logcat

mozilla::layers::AsyncPanZoomController::OnTouchEndOrCancel()
Does this happen on 1.4?
blocking-b2g: --- → 2.0?
Component: General → Graphics: Layers
Product: Firefox OS → Core
Version: unspecified → Trunk
Component: Graphics: Layers → Panning and Zooming
This is a bug 976605 regression, with an easy fix which I'll post. Sorry about that!
Assignee: nobody → botond
Keywords: qawanted
Blocks: 976605
Attachment #8407807 - Flags: review?(bugmail.mozilla) → review+
I just replicated this whilst using Cards View. I had Usage, Settings and Browser apps open. I was trying to swipe to kill one of the apps when it crashed.

Gaia      37d029e584d79aeaca8d30474c394eddcdfade03
Gecko     https://hg.mozilla.org/mozilla-central/rev/b735e618c2a8
BuildID   20140416160202
Version   31.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
(In reply to Botond Ballo [:botond] from comment #5)
> Try push: https://tbpl.mozilla.org/?tree=Try&rev=b25673508598

Got tired of waiting for OS X 10.8 Opt, it's been queued up since yesterday afternoon. Try push is otherwise clean.

https://hg.mozilla.org/integration/mozilla-inbound/rev/111a943b2c7a
Duplicate of this bug: 997878
https://hg.mozilla.org/mozilla-central/rev/111a943b2c7a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Could not repro crash on latest Buri 1.5 so verifying fixed.

1.5 Environmental Variables:
Device: Buri 1.5 MOZ
BuildID: 20140418040202
Gaia: 375d87bfef8a5d7135f139da8c17f237b990d3f5
Gecko: 7fe3ee0cf8be
Version: 31.0a1
Firmware Version: V1.2-device.cfg
Status: RESOLVED → VERIFIED
blocking-b2g: 2.0? → 2.0+
You need to log in before you can comment on or make changes to this bug.