CSS body background image doesn't display through tables

RESOLVED INVALID

Status

()

Core
CSS Parsing and Computation
--
minor
RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: Chris van der Pennen, Assigned: dbaron)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

The background image and colour (black) at maq.ausgamers.com (defined in
http://maq.ausgamers.com/maq.css) should be showing through the tables (Internet
Explorer).  It isn't.  There are some <DIV> tags as well, not sure what they do
but they might have something to do with it.

Reproducible: Always
Steps to Reproduce:
1.  Visit http://maq.ausgamers.com in Moz. and see a white background.
2.  Visit the same page in Internet Explorer (as the page says) and see how it
should look.


Actual Results:  I got a white background in Moz. instead of a black one with
the MaQ logo.

Expected Results:  Moz. should have displayed the background image and colour
through the tables.
The page has a number of errors in the stylesheet.  The one that is the error
that's causing the problems is the following declaration:
 
background:#000000 url(maqlogo.jpg) no-repeat center 200px;

If I'm reading the spec correctly, the 'background-position' property, for which
you attempt to give 'center 200px', takes either keywords or
lengths/percentages, but never a mix of the two.

According to the error handling requirements of the CSS spec (7.1 of CSS1,
chapter 4 of CSS2), we must, for interoperability, ignore invalid declarations.
 Therefore marking this bug INVALID (although I admit the grammar of
'background-position' seems a little strange).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Created attachment 49435 [details]
testcase showing we correctly handle valid 'background-position' (50% 200px)
Created attachment 49436 [details]
testcase showing we correctly ignore invalid 'background-position' (center 200px)
FWIW, the errors in the stylesheet are:

line 2: "center 200px" should be changed to "50% 200px"
line 2: the value for clip is invalid and I don't know what was intended
line 18: 'none' is not a valid value for 'background-color'.  Maybe 'transparent'?

There's also an error in inline style on the page itself, where 'visibility:
hide' should be 'visibility: hidden'.  Normally
http://jigsaw.w3.org/css-validator/ would tell you this but it seems to be
having some problems right now.
You need to log in before you can comment on or make changes to this bug.