Closed Bug 997402 Opened 6 years ago Closed 6 years ago

both bing and yahoo params are broken

Categories

(Firefox for Android :: General, defect)

27 Branch
x86_64
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: mconnor, Assigned: mconnor)

Details

(Keywords: regression)

Attachments

(1 file)

Attached patch paramNotMozParamSplinter Review
Found in testing inbound builds.

MozParam, despite the name, is not quite like Param.  It works only if there's a condition attached, otherwise it's ignored (silently).  I'm going to file a followup on the search service to warn somewhat noisily when that happens, but in the meantime this is now broken across branches.  Automated testing bugs getting filed today or tomorrow so we don't regress this again, but I'll manually test ASAP.

That sound you hear is me quietly whacking my head on the desk.
Attachment #8407802 - Flags: review?(mark.finkle)
Comment on attachment 8407802 [details] [diff] [review]
paramNotMozParam

I found bug 351817 was where we added MozParam. Too bad it doesn't have a fallback, but know I know.
Attachment #8407802 - Flags: review?(mark.finkle) → review+
Comment on attachment 8407802 [details] [diff] [review]
paramNotMozParam

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 984530
User impact if declined: no tags on searches, Mozilla loses money
Testing completed (on m-c, etc.): manual
Risk to taking this patch (and alternatives if risky): very tiny
String or IDL/UUID changes made by this patch: none
Attachment #8407802 - Flags: approval-mozilla-beta?
Attachment #8407802 - Flags: approval-mozilla-aurora?
Attachment #8407802 - Flags: approval-mozilla-beta?
Attachment #8407802 - Flags: approval-mozilla-beta+
Attachment #8407802 - Flags: approval-mozilla-aurora?
Attachment #8407802 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/ae057f9c301b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
I can't hear the sound because I'm violently banging my head against the wall...

I guess this has just become part of bug 994248.
You need to log in before you can comment on or make changes to this bug.