Back button does not update Location: if page not 100% loaded

VERIFIED WORKSFORME

Status

P1
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: cpratt, Assigned: radha)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build ID: 1999071417
Platform: Windows 98 (can't test Mac OS or Linux just yet)

To reproduce:

- Launch apprunner
- Go to a Web page with many links (preferably over a slow connection)
- After you have followed a link, click a link on the new page that's currently
loading without waiting for it to finish loading
- At the new page (the third in the series), wait for it to finish loading
- Click Back

Result: You go back one page, but it does not load correctly. As far as I can
tell, if it didn't load 100% the first time, no attempt is made to load all of
it this time. The Location: control is no updated with the correct URL (showing
instead the third page in the series); images that did not load the first time
are not loaded.

Comment 1

19 years ago
Reassign to don/xpapps. See comments on 9973 -- same applies here I think.
Assignee: waterson → don

Updated

19 years ago
Assignee: don → radha
Component: RDF → XPApps
Priority: P3 → P2
Target Milestone: M11

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: Waiting QA Input
I can't reproduce this. My fix for 5624 kinda helps fixing this too. Please
verify.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
QA Contact: phillip → cpratt
Whiteboard: Waiting QA Input
(Reporter)

Comment 3

19 years ago
This is fixed in 19990929xx builds, windows 98. Verifying.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.