Closed Bug 997513 Opened 8 years ago Closed 6 years ago

Intermittent testMasterPassword | Exception caught - junit.framework.AssertionFailedError: Button with text: 'OK' is not found!

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1216257

People

(Reporter: RyanVM, Assigned: gbrown)

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=37958600&tree=Mozilla-Inbound

Android 2.2 Tegra mozilla-inbound opt test robocop-1 on 2014-04-16 14:27:30 PDT for push 95e6b5e31ce1
slave: tegra-254

0 INFO SimpleTest START
1 INFO TEST-START | testMasterPassword
2 INFO TEST-PASS | testMasterPassword | Given message occurred for registered event: {"type":"Gecko:Ready"} - Gecko:Ready should equal Gecko:Ready
EventExpecter: no longer listening for Gecko:Ready
waitForText timeout on ^Settings$
waitForText timeout on ^Create Master Password$
Exception caught during test!
junit.framework.AssertionFailedError: Button with text: 'OK' is not found!
	at junit.framework.Assert.fail(Assert.java:47)
	at junit.framework.Assert.assertTrue(Assert.java:20)
	at com.jayway.android.robotium.solo.Getter.getView(Getter.java:67)
	at com.jayway.android.robotium.solo.Solo.getButton(Solo.java:1920)
	at org.mozilla.gecko.tests.testMasterPassword.enableMasterPassword(testMasterPassword.java:30)
	at org.mozilla.gecko.tests.testMasterPassword.testMasterPassword(testMasterPassword.java:17)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:204)
	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:194)
	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:186)
	at org.mozilla.gecko.tests.BaseTest.runTest(BaseTest.java:125)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:520)
	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1447)
3 INFO TEST-UNEXPECTED-FAIL | testMasterPassword | Exception caught - junit.framework.AssertionFailedError: Button with text: 'OK' is not found!
4 INFO TEST-END | testMasterPassword | finished in 71192ms
5 INFO TEST-START | Shutdown
6 INFO Passed: 1
7 INFO Failed: 1
8 INFO Todo: 0
9 INFO SimpleTest FINISHED
I don't see how it could be related, but this test was just modified in bug 971743.
04:25:55     INFO -  05-08 04:25:04.757 I/Robocop ( 2711): 19 INFO TEST-PASS | testMasterPassword | Checking if Save option is present - Save option is present
04:25:55     INFO -  05-08 04:25:05.843 V/tiny_hw ( 1294): out_write(0x1f4c160) opening PCM
04:25:55     INFO -  05-08 04:25:05.953 E/GeckoConsole( 2711): Sending message
04:25:55     INFO -  05-08 04:25:06.351 D/GeckoLayerClient( 2711): Window-size changed to (1280,280)
04:25:55     INFO -  05-08 04:25:07.617 D/GeckoLayerClient( 2711): Window-size changed to (1280,616)
04:25:55     INFO -  05-08 04:25:08.867 V/tiny_hw ( 1294): out_standby(0x1f4c160) closing PCM
04:25:55     INFO -  05-08 04:25:09.500 V/tiny_hw ( 1294): out_write(0x1f4c160) opening PCM
04:25:55     INFO -  05-08 04:25:09.523 E/GeckoConsole( 2711): Sending message
04:25:55     INFO -  05-08 04:25:09.578 E/tiny_hw ( 1294): out_write(0x1f4c160) failed: -32
04:25:55     INFO -  05-08 04:25:09.609 E/tiny_hw ( 1294): out_write(0x1f4c160) failed: -32
04:25:55     INFO -  05-08 04:25:10.007 D/GeckoLayerClient( 2711): Window-size changed to (1280,280)
04:25:55     INFO -  05-08 04:25:11.234 D/GeckoLayerClient( 2711): Window-size changed to (1280,616)
04:25:55     INFO -  05-08 04:25:12.109 D/GeckoLayerClient( 2711): Window-size changed to (1280,280)
04:25:55     INFO -  05-08 04:25:12.507 V/tiny_hw ( 1294): out_standby(0x1f4c160) closing PCM
04:25:55     INFO -  05-08 04:25:12.703 D/GeckoLayerClient( 2711): Window-size changed to (1280,616)
04:25:55     INFO -  05-08 04:25:14.695 V/tiny_hw ( 1294): out_write(0x1f4c160) opening PCM
04:25:55     INFO -  05-08 04:25:14.742 E/tiny_hw ( 1294): out_write(0x1f4c160) failed: -32
04:25:55     INFO -  05-08 04:25:14.773 E/tiny_hw ( 1294): out_write(0x1f4c160) failed: -32
04:25:55     INFO -  05-08 04:25:16.187 E/GeckoConsole( 2711): Sending message
04:25:55     INFO -  05-08 04:25:16.273 I/LatinIME( 1547): InputType.TYPE_NULL is specified
04:25:55     INFO -  05-08 04:25:16.289 W/LatinIME( 1547): Unexpected input class: inputType=0x00000000 imeOptions=0x00000000
04:25:55     INFO -  05-08 04:25:16.625 D/GeckoLayerClient( 2711): Window-size changed to (1280,280)
04:25:55     INFO -  05-08 04:25:16.890 E/GeckoConsole( 2711): [JavaScript Error: "[Exception... "User canceled master password entry"  nsresult: "0x80004004 (NS_ERROR_ABORT)"  location: "JS frame :: jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/crypto-SDR.js :: LoginManagerCrypto_SDR.prototype.encrypt :: line 115"  data: no]" {file: "jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/crypto-SDR.js" line: 115}]
04:25:55     INFO -  05-08 04:25:16.890 E/GeckoConsole( 2711): [JavaScript Error: "[Exception... "User canceled master password entry"  nsresult: "0x80004004 (NS_ERROR_ABORT)"  location: "JS frame :: jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/crypto-SDR.js :: LoginManagerCrypto_SDR.prototype.encrypt :: line 115"  data: no]" {file: "jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/crypto-SDR.js" line: 115}]
04:25:55     INFO -  05-08 04:25:16.890 E/GeckoConsole( 2711): [JavaScript Error: "[Exception... "User canceled master password entry"  nsresult: "0x80004004 (NS_ERROR_ABORT)"  location: "JS frame :: jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/crypto-SDR.js :: LoginManagerCrypto_SDR.prototype.encrypt :: line 115"  data: no]" {file: "jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/crypto-SDR.js" line: 115}]
04:25:55     INFO -  05-08 04:25:16.890 E/GeckoConsole( 2711): [JavaScript Error: "NS_ERROR_ABORT: User canceled master password entry" {file: "jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/crypto-SDR.js" line: 115}]
04:25:55     INFO -  05-08 04:25:16.953 D/GeckoLayerClient( 2711): Window-size changed to (1280,616)
04:25:55     INFO -  05-08 04:25:17.398 I/LatinIME( 1547): InputType.TYPE_NULL is specified
04:25:55     INFO -  05-08 04:25:17.398 W/LatinIME( 1547): Unexpected input class: inputType=0x00000000 imeOptions=0x00000000
04:25:55     INFO -  05-08 04:25:17.492 D/GeckoLayerClient( 2711): Window-size changed to (1280,280)
04:25:55     INFO -  05-08 04:25:17.703 V/tiny_hw ( 1294): out_standby(0x1f4c160) closing PCM
04:25:55     INFO -  05-08 04:25:19.781 E/GeckoConsole( 2711): 1399523119791	addons.update-checker	WARN	Request failed: http://10.12.136.19:30816/extensions-dummy/updateBackgroundURL - 404: Not Found
04:25:55     INFO -  05-08 04:25:19.781 I/Gecko   ( 2711): 1399523119791	addons.update-checker	WARN	Request failed: http://10.12.136.19:30816/extensions-dummy/updateBackgroundURL - 404: Not Found
04:25:55     INFO -  05-08 04:25:19.796 E/GeckoConsole( 2711): 1399523119800	addons.update-checker	WARN	Request failed: http://10.12.136.19:30816/extensions-dummy/updateBackgroundURL - 404: Not Found
04:25:55     INFO -  05-08 04:25:19.796 I/Gecko   ( 2711): 1399523119800	addons.update-checker	WARN	Request failed: http://10.12.136.19:30816/extensions-dummy/updateBackgroundURL - 404: Not Found
04:25:55     INFO -  05-08 04:25:19.812 E/GeckoConsole( 2711): 1399523119812	addons.update-checker	WARN	Request failed: http://10.12.136.19:30816/extensions-dummy/updateBackgroundURL - 404: Not Found
04:25:55     INFO -  05-08 04:25:19.812 I/Gecko   ( 2711): 1399523119812	addons.update-checker	WARN	Request failed: http://10.12.136.19:30816/extensions-dummy/updateBackgroundURL - 404: Not Found
04:25:55     INFO -  05-08 04:25:37.960 I/Robocop ( 2711): waitForText timeout on ^OK$
04:25:55     INFO -  05-08 04:25:48.171 I/dalvikvm-heap( 2711): Grow heap (frag case) to 11.411MB for 3440656-byte allocation
04:25:55     INFO -  05-08 04:25:48.250 I/Robocop ( 2711): Exception caught during test!
04:25:55     INFO -  05-08 04:25:48.250 I/Robocop ( 2711): junit.framework.AssertionFailedError: Button with text: '^OK$' is not found!
04:25:55     INFO -  05-08 04:25:48.250 I/Robocop ( 2711): 	at junit.framework.Assert.fail(Assert.java:47)
04:25:55     INFO -  05-08 04:25:48.250 I/Robocop ( 2711): 	at junit.framework.Assert.assertTrue(Assert.java:20)
04:25:55     INFO -  05-08 04:25:48.250 I/Robocop ( 2711): 	at com.jayway.android.robotium.solo.Clicker.clickOn(Clicker.java:407)
04:25:55     INFO -  05-08 04:25:48.250 I/Robocop ( 2711): 	at com.jayway.android.robotium.solo.Solo.clickOnButton(Solo.java:823)
04:25:55     INFO -  05-08 04:25:48.250 I/Robocop ( 2711): 	at org.mozilla.gecko.tests.testMasterPassword.verifyLoginPage(testMasterPassword.java:208)
04:25:55     INFO -  05-08 04:25:48.250 I/Robocop ( 2711): 	at org.mozilla.gecko.tests.testMasterPassword.testMasterPassword(testMasterPassword.java:18)
testMasterPassword was disabled on Android 4.0 in bug 1006242.
Whiteboard: [test disabled on Android 4.0][leave open]
Sorry comment 30 was a mis-star, from real bustage fixed by backout (push a033a0b332eb).
This test has been deleted.
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: [test disabled on Android 4.0][leave open]
Duplicate of bug: 1216257
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.