Can't ever close progress window for failed XPI installation

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
3 years ago

People

(Reporter: mpt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: 2001091405, Mac OS 9.1

To reproduce:
1.  Go to <http://x.themes.org/viewresources.phtml?type=chrome>.
2.  Click on any of the `Install' links, and begin installation.
3.  While the theme is downloading, unplug your modem and disconnect from the
    Internet.
4.  Reconnect.
5.  Try to get rid of the progress window.

What happens:
*   The window cannot be closed until you quit Mozilla.

What should happen:
*   The `Cancel' button should close the window.

Comment 1

17 years ago
Changed Component & QA Contact
Component: Installer: XPI Packages → Installer: XPInstall Engine
QA Contact: ktrina → jimmylee

Comment 2

17 years ago
over to Curt.
Assignee: ssu → curt
Target Milestone: --- → mozilla0.9.8

Updated

17 years ago
Target Milestone: mozilla0.9.8 → ---

Comment 3

17 years ago
It would be great to get this fixed, but I recommend "nsbeta1-" because
unfortunately, there are other defects that require more immediate attention.

Comment 4

15 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Updated

15 years ago
OS: Mac System 8.5 → All
Hardware: Macintosh → All

Comment 5

10 years ago
This bug hasen't been touched for years and is clearly unowned. Moving back to default assignee/QA so that people, who are watching those can accurately triage this bug.

Also resetting Priority, Target Milestone, Status Whiteboard and Status.
Assignee: curt → nobody
QA Contact: jimmykenlee → xpi-engine
Add-on installation has been rewritten (more than once) since this bug was filed; under the new UI I can cancel an add-on install while it is downloading (tested by pulling my network connection while the download was in progress).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

3 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.