Closed Bug 997580 Opened 6 years ago Closed 6 years ago

[Bluetooth][Certification][PTS][Bluedroid][1.4] HFP TC_AG_TWC_BV_03_I

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, firefox29 wontfix, firefox30 fixed, firefox31 fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

VERIFIED FIXED
1.4 S6 (25apr)
blocking-b2g 1.4+
Tracking Status
firefox29 --- wontfix
firefox30 --- fixed
firefox31 --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: yrliou, Assigned: yrliou)

References

Details

Attachments

(1 file, 3 obsolete files)

This case is originally be filed in bug993288.
File a new bug for TC_AG_TWC_BV_02_I only because the cause is not the same.
Please refer to the comment link below for QA message.
https://bugzilla.mozilla.org/show_bug.cgi?id=993288#c3

Depends on bug993280 because we need to respond OK for AT+CHLD command.
Depends on bug993288 for sending +CCWA to HF.
blocking-b2g: --- → 1.4?
While handling CHLD=2, call status changes:
    1) call1 is active, call2 is held
    2) both calls are active, no call is held
    3) call2 is active, call1 is held
2) is a temporary status and will lead to PTS fail if we send a +CIEV indicating this status.
In this patch, I add a logic to eliminate this status notification and pass the test case.
We might also need to consider how to figure out and handle other temporary states which caused by swap/merge calls in the future.
Attachment #8409614 - Flags: feedback?(btian)
Comment on attachment 8409614 [details] [diff] [review]
Patch1(v1) Bug 997580: Do not send +CIEV which indicates a temporary state while processing CHLD=2

Review of attachment 8409614 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/bluetooth/bluedroid/hfp/BluetoothHfpManager.cpp
@@ +1136,5 @@
> +  // in held mode which leads to PTS test fail because we send out the +CIEV for
> +  // this temporary state.
> +  // TODO: Review other circumstances which will send out +CIEV that indicates a
> +  // temporary state, for example, CHLD=1.
> +  if (!(aCallState == nsITelephonyProvider::CALL_STATE_CONNECTED &&

The logic assumes the 1st call state change for CHLD=2 is HELD->CONNECTED. I think the 1st call change might be CONNECTED->HELD as well. Please add condition to handle random call state change order.

Also please note in comment that the logic doesn't handle conference call cases.
blocking-b2g: 1.4? → 1.4+
Hi Ben,

Thanks for your feedback, I have update the patch to cover random change sequences for CHLD=2.
Also detect some invalid temporary state while processing conference call.
Please let me know if you have any comments on the updated version.

Thanks,
Jocelyn
Attachment #8409614 - Attachment is obsolete: true
Attachment #8409614 - Flags: feedback?(btian)
Attachment #8410731 - Flags: feedback?(btian)
Minor update on the comments
Attachment #8410731 - Attachment is obsolete: true
Attachment #8410731 - Flags: feedback?(btian)
Attachment #8410823 - Flags: feedback?(btian)
Since Jocelyn is PTS, I'll continue to work on this bug.

This patch removes conference call part and is rebased on bug 993286's patches.
Attachment #8410823 - Attachment is obsolete: true
Attachment #8410823 - Flags: feedback?(btian)
Attachment #8411565 - Flags: review?(echou)
(In reply to Ben Tian [:btian] from comment #5)
> Since Jocelyn is PTS, I'll continue to work on this bug.

typo: should be 'PTO'
Comment on attachment 8411565 [details] [diff] [review]
[final] Patch 1: Don't notify bluedroid of callstate change during transition, r=echou, a=1.4+

Review of attachment 8411565 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8411565 - Flags: review?(echou) → review+
Keywords: checkin-needed
Attachment #8411565 - Attachment description: Patch 1 (v3): Don't notify bluedroid of callstate change durding transition → [final] Patch 1: Don't notify bluedroid of callstate change during transition, r=echou, a=1.4+
https://hg.mozilla.org/mozilla-central/rev/c484a11fc735
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S1 (9may)
You need to log in before you can comment on or make changes to this bug.