Closed Bug 997625 Opened 7 years ago Closed 7 years ago

Sync panel: Checkbox for syncing passwords enabled (not disabled) while sync credentials need reauth

Categories

(Firefox :: Preferences, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 + verified
firefox30 + verified
firefox31 + verified

People

(Reporter: aryx, Assigned: aryx)

Details

(Keywords: regression, Whiteboard: [good first verify] [testday-20140509])

Attachments

(1 file)

Latest Nightly on Windows 8.1

Regression from bug 970167.

When the user has successfully set up sync locally but syncing fails on the server side (e.g. password changed on the server but not locally), the checkboxes what kind of data should be sync become disabled except the password checkbox.
Comment on attachment 8408178 [details] [diff] [review]
patch, v2

Review of attachment 8408178 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8408178 - Flags: review?(ttaubert) → review+
Tracking for 30 and 31.

Do you want to have in 29?
Yes, I think it would be really great to have this in 29. It's a very visible glitch and a very trivial fix.
OK. Can you fill the uplift request?
Comment on attachment 8408178 [details] [diff] [review]
patch, v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 970167
Testing completed (on m-c, etc.): Manual smoke testing.
Risk to taking this patch (and alternatives if risky): Low risk.
String or IDL/UUID changes made by this patch: None.

User impact if declined: 
Without this patch the checkbox for the passwords sync engine will always be enabled. When signed in with an unverified email address all checkboxes are disabled except the passwords engine, which looks really off and is very visible.
Attachment #8408178 - Flags: approval-mozilla-beta?
Attachment #8408178 - Flags: approval-mozilla-aurora?
Attachment #8408178 - Flags: approval-mozilla-beta?
Attachment #8408178 - Flags: approval-mozilla-beta+
Attachment #8408178 - Flags: approval-mozilla-aurora?
Attachment #8408178 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/e73e1719edcb
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Whiteboard: [good first verify]
Verified fixed in 29, 30, and 31 on Windows 8.1 x64
Status: RESOLVED → VERIFIED
Whiteboard: [good first verify] → [good first verify] [testday-20140509]
You need to log in before you can comment on or make changes to this bug.