Bookmarks - File | New Window not the correct naming

VERIFIED FIXED in M16

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: cpratt, Assigned: Steve Lamm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build ID: 1999071417, 1999071208 (M8 builds)
Platform: Windows 98 (can't test Mac OS or Linux right now, but presumably the
same on those platforms as well)

To reproduce:
- Launch apprunner
- Select Bookmarks | Manage Bookmarks…
- In the Bookmarks window, drop down the File menu

Result: There is a menu item that reads 'New Window'

Expected result: There should be a menu item that reads 'New' that reveals a
submenu with different items there, eg Navigator Window, Mail Message, etc. As
only one bookmarks window can be open at one time, it does not make sense to
have a 'New Window' menu item in this context.

Comment 1

19 years ago
technically this isn't a bug because 'New Window' when in the bookmarks context does exactly that. It opens a new, fully
functional mange bookmarks window. So it shouldn't be called anything else, unless you're looking for different functionality,
which would be a feautre request. Why one would ever need two bookmarks windows, I dunno, someone else can make that call.
(Reporter)

Comment 2

19 years ago
According to the spec at http://gooey/client/5.0/specs/bnh/, this is a bug as
far as I can tell. cc'ing german.

Updated

19 years ago
Component: UE/UI → XPApps

Comment 3

19 years ago
'looking at the spec' shows me that the current state and the desired state are two different things i.e. there is still much work to
be done there. Therefore I imagine this work is on someone's task list. My little brain says it's slamm so i'm cc'ing him.

Slamm: please dupe if you already have a bug attached to this task.

changing component as it's more than a UE issue or rather the UI work has already been done.

Comment 4

19 years ago
cc'ing slamm for real this time; you may want to look at bug 9980 as well.

Updated

19 years ago
Assignee: shuang → german

Comment 5

19 years ago
german should be the one that make a decision on the naming.

Updated

19 years ago
Assignee: german → slamm
Target Milestone: M10

Comment 6

19 years ago
We will not have a "New" item by itself in the Manage Bookmarks window, since it
does not make sense to open two Manage Bookmarks windows at the same time. The
New > popout submenus will have the same content as in other app windows.
Slamm can you update the menus to reflect this, I changed the target to M10,
since I know your plate is already full for m9, plus we need to coordinate to
see whether we can create an overlay for the File menu, to be used in all apps.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Target Milestone: M12 → M14
(Assignee)

Comment 7

19 years ago
Hangas, would you be able to help me add a "New>" submenu to the bookmarks and
history windows?

Updated

18 years ago
Component: XPApps → Bookmarks

Comment 8

18 years ago
Looks to me like this is fixed in 2000020310 NT.  Could we verify it? 

Marking Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
I'm gonna say no at this point.
what we have now is a toplevel menu titled 'File' with submenuitems:
New Bookmark
New Folder
New Separator

I don't know how authoratative the specs are (last updated 10/01/99) - I may be looking at the wrong ones but none of this is 
spec. If someone wants to make a call and say this is what we are going with for Beta1 then do so. Until I hear otherwise, this bug 
is REOPENED.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 10

18 years ago
Move to M16 ...
Target Milestone: M14 → M16

Updated

18 years ago
Keywords: nsbeta2
(Assignee)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

18 years ago
I just checked in a fix.

Comment 12

18 years ago
VERIFIED Fixed with 2000051012 builds
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.