Closed Bug 997961 Opened 8 years ago Closed 6 years ago

Closing tag highlight needs to be higher contrast ( dark theme )

Categories

(DevTools :: Inspector, defect)

30 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1246313

People

(Reporter: canuckistani, Unassigned)

Details

Attachments

(2 files)

If you're using the dark theme there is a nice feature where ( for an expanded tag with children ) the line with the closing tag is highlighted for the selected opening tag. Problem is, the color chosen for the closing tag line is very dark and hard to see, it should be lighter in order to be generally more useful.

User screencast: http://quick.as/zxqtklg
OS: Mac OS X → All
Hardware: x86 → All
The only other place using theme-bg-darker is the alternating row styling on the computed view (see screenshot)
Of course this will be an easy fix if we can decide on an appropriate color.  Jeff, are you suggesting that the color is lighter than the background?  If we make it lighter than it is currently it will actually lower the contrast *until* it gets lighter than the original background.  We could also make it darker or add a bit of another color to make it stand out.
Flags: needinfo?(jgriffiths)
Sorry, what I'm suggesting is that there should be a great difference between the background and the color in question. I'm not a designer but it seems to me that with an already dark background you have more room in the colour spectrum getting lighter than getting darker.

I've also realized after some experimentation that my cheap monitor here at home makes things worse. For example, if I switch to the light theme the closing tag highlight color *is* visible on my Macbook Air's built-in LCD, but it is completely invisible on my monitor. 

I don't think the bad-monitor-settings factor invalidates this bug, in fact I think we need to be aware that not everyone has a decent monitor, and that higher-contrast improves usability.
Flags: needinfo?(jgriffiths)
Both the light and dark theme got refreshed IIRC. Helen, do you think this bug is still valid ?
Flags: needinfo?(hholmes)
(In reply to Nicolas Chevobbe from comment #5)
> Both the light and dark theme got refreshed IIRC. Helen, do you think this
> bug is still valid ?

I think this can safely be marked a duplicate of bug 1246313.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(hholmes)
Resolution: --- → DUPLICATE
Duplicate of bug: 1246313
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.