Closed Bug 998044 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Dialer]Speakerphone and Mute buttons do not work

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T verified, b2g-v1.4 unaffected, b2g-v2.0 unaffected)

VERIFIED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- verified
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected

People

(Reporter: rkuhlman, Assigned: etienne)

References

Details

(Keywords: smoketest, Whiteboard: [sprd302711][partner-blocker][tarako_only])

Attachments

(2 files)

When in a phone call, the user can choose to put the call on speakerphone, or the can mute the audio. Neither of these buttons work in the latest tarako build. The buttons will briefly flash when tapped, but otherwise no changes occur.

Repro Steps:
1) Update Tarako to BuildID: 20140417004002
2) Launch Dialer.
3) Call a valid phone number.
4) During phone call, tap the speakerphone or mute buttons.

Actual:
Speakerphone and Mute buttons do not function.
 
Expected:
Speakerphone and Mute buttons function.

v1.3T Environmental Variables:
Device: Buri v1.3T 
BuildID: 20140417004002
Gaia: a8d2d399f2939f4845abaa0df57abab241a2c782
Gecko: d97dad54cb61
Version: 28.1
Firmware Version: sp6821


Repro frequency: 100%
See attached: logcat
We're suppose to get a new PAC file soon.  Hopefully it doesn't exhibit in that.  Just in case noming.
blocking-b2g: --- → 1.3T?
From log, The switch command do the right routing control. Partner needs to take a look.


1. MO call starts
04-17 14:43:44.793: V/AudioPolicyManagerBase(88): setPhoneState() state 2

2. Switch to speaker
04-17 14:43:49.883: V/AudioPolicyManagerBase(88): setOutputDevice() routing=2

3. Switch to earpiece
04-17 14:43:50.163: V/AudioPolicyManagerBase(88): setOutputDevice() routing=1

4. Switch to speaker
04-17 14:43:53.243: V/AudioPolicyManagerBase(88): setOutputDevice() routing=2

5. ......
Flags: needinfo?(james.zhang)
see bug http://bugzilla.spreadtrum.com/bugzilla/show_bug.cgi?id=302711
Please contact tony.li to discuss.
Flags: needinfo?(james.zhang)
Sorry, comment 2 is wrong.

From log, AudioPolicy receive command to route for DEVICE_OUT_SPEAKER(2), and immediately(<1sec) receive another command to route for DEVICE_OUT_EARPIECE(1). Please Gaia owner have a check for 2 things:

1. Receive 2 times touch event? or
2. Send 2 times switch command?

Thanks

04-17 14:43:44.843: V/AudioPolicyManagerBase(88): setOutputDevice() routing=1
04-17 14:43:49.883: V/AudioPolicyManagerBase(88): setOutputDevice() routing=2
04-17 14:43:50.163: V/AudioPolicyManagerBase(88): setOutputDevice() routing=1
04-17 14:43:53.243: V/AudioPolicyManagerBase(88): setOutputDevice() routing=2
04-17 14:43:53.523: V/AudioPolicyManagerBase(88): setOutputDevice() routing=1
04-17 14:43:58.663: V/AudioPolicyManagerBase(88): setOutputDevice() routing=2
04-17 14:43:58.923: V/AudioPolicyManagerBase(88): setOutputDevice() routing=1
04-17 14:44:01.553: V/AudioPolicyManagerBase(88): setOutputDevice() routing=2
04-17 14:44:01.863: V/AudioPolicyManagerBase(88): setOutputDevice() routing=1
Flags: needinfo?(etienne)
blocking-b2g: 1.3T? → 1.3T+
Whiteboard: [sprd302711]
Duplicate of this bug: 998154
Whiteboard: [sprd302711] → [sprd302711][partner_blocker]
Whiteboard: [sprd302711][partner_blocker] → [sprd302711][partner-blocker]
also ni? Rik as there are quite a few bugs on Etienne already. see if Rik can offload a bit. thanks
Flags: needinfo?(anthony)
Assignee: nobody → etienne
Flags: needinfo?(etienne)
Flags: needinfo?(anthony)
Attached file Gaia PR against 1.3t
Attachment #8410280 - Flags: review?(anthony)
This was caused by a bad merge. This patch is tarako only.

Sorry.


(we were adding the click listener twice, which isn't cool for a toggle button :))
Whiteboard: [sprd302711][partner-blocker] → [sprd302711][partner-blocker][tarako-only]
Duplicate of this bug: 999347
Duplicate of this bug: 997394
Keywords: smoketest
Not a smoketest blocker.
Keywords: smoketest
(In reply to Jason Smith [:jsmith] from comment #11)
> Not a smoketest blocker.

Disregard - missed the fact that bug 997394 was already a smoketest blocker.
Keywords: smoketest
Comment on attachment 8410280 [details] [review]
Gaia PR against 1.3t

Oopsie
Attachment #8410280 - Flags: review?(anthony) → review+
Hi! James,

Check in needed. Thanks

--
Keven
Flags: needinfo?(james.zhang)
Keywords: checkin-needed
(In reply to Keven Kuo [:kkuo] from comment #14)
> Hi! James,
> 
> Check in needed. Thanks
> 
> --
> Keven

Done.
https://github.com/mozilla-b2g/gaia/commit/f67c697dbed20b222dfcd81e41eb012dba0d62b9
Flags: needinfo?(james.zhang)
Closing this under the assumption that this was 1.3t-only. Please don't forget to mark the bugs when you push.
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Verified fixed on the latest 1.3T build.

The Mute and Speaker buttons are working properly. Pressing buttons in the number pad while in a call are working correctly and only showing 1 number as expected.

1.3 Environmental Variables:
Device: Tarako 1.3
BuildID: 20140424014003
Gaia: 706f474230432c8cb01e124aee2c055ec902aa1d
Gecko: 26ef3dded9ff
Version: 28.1
Firmware Version: sp6821
Status: RESOLVED → VERIFIED
Whiteboard: [sprd302711][partner-blocker][tarako-only] → [sprd302711][partner-blocker][tarako_only]
Verified comments #17 findings on latest v1.3T Tarako build. Updating tracking flag.
You need to log in before you can comment on or make changes to this bug.