Double-click selects multiple words if no space...

VERIFIED FIXED in M12

Status

()

Core
Selection
P3
normal
VERIFIED FIXED
19 years ago
15 years ago

People

(Reporter: cpratt, Assigned: mjudge)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Build ID: 1999071417
Platform: Windows 98 (haven't tested Mac OS or Linux yet)

To reproduce:
- Load the attached test case in apprunner
- Double-click the word 'Grendel'

Result: Both 'Grendel' and 'Wednesday' are highlighted

Expected result: Only 'Grendel' is

Here's the offending HTML:

<FONT FACE="Trebuchet MS, Helvetica, Arial, sans-serif" SIZE="+1">
 <B><!--head-->ZDNet Article on Jazilla and Grendel<!--head-end--></B></font>
                 <BR>
               <FONT COLOR="#999966" FACE="Trebuchet MS, Helvetica, Arial,
sans-serif">
                            <B>Wednesday July 14th, 1999</B>
                          </FONT>

- The problem seems to be that apprunner sees that there is no space between
Grendel and Wednesday - but logically, there should be because of the <BR> tag
between the two.
(Reporter)

Comment 1

19 years ago
Created attachment 905 [details]
Test case for this bug

Comment 2

19 years ago
Confirmed on this morning's Mac OS and yesterday's 99071514 Linx build. Good
catch.
(Assignee)

Comment 3

19 years ago
*** Bug 11544 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

19 years ago
*** Bug 12129 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

19 years ago
*** Bug 6875 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

19 years ago
*** Bug 10279 has been marked as a duplicate of this bug. ***

Comment 7

19 years ago
[Note to self: many of these bugs contain variant bug manifestations; be sure to
verify the issues documented by the duplicate bugs are also fixed while verifying
the bug.]

Updated

19 years ago
Target Milestone: M12

Comment 8

19 years ago
this really should get fixed for beta.  Might be a dup.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

19 years ago
fixed. i must get sleep.. must make it. must fix bugs...

Comment 10

19 years ago
Seems mostly fixed, but try resource:///res/samples/test1.html , double-clicking
just after the bullets:
* [^here] Oranges

Comment 11

19 years ago
Oh boy, here it goes, noting that this bug can't be marked Verified until the
double-click on Mac bug is fixed.

First, let's start with the dependent bugs. All of the following were tested on
the 1999101308 Win32 and Linux builds:

	1. 11544 has been re-opened by Akkana; didn't verify.
	2. 12129 appears fixed.
	3. 6875 has been re-opened by me. (Additionally, there's still a space being
selected after items immediately prior to a child nested list, but I believe
that's covered by Akkana'a 11544.)
	4. 10279 appears fixed on Win32 and Linux.

Comment 12

19 years ago
The actual bug reported here by cpratt is now Verified/Fixed on Win32 & Linux
(same build dates)

Re: al@heimdallr.u-net.com's good observation (thanks!), I believe this is
covered by the now-reopened 6875. If not, someone please say something.

Updated

19 years ago
Depends on: 14990

Comment 13

19 years ago
[Marking as dependent upon 14990.]

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 14

19 years ago
Using 1999 10/18 09:00 Mac Mozilla build, verified that:
	* this bug is fixed.
	* 12129 is also fixed.
	* 10279 cannot be verified --- editor is busted on Mac. Trusting it to be an
actual duplicate. (famous last words)

Comment 15

19 years ago
Okay. 10279 verified on today's Mac build; I can go home contented now... ;)
You need to log in before you can comment on or make changes to this bug.