[Tarako][Dialer]Connect headset, cannot hear complete speak out sentence from Tarako to MT

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mlien, Assigned: sam.hua)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.3T+, b2g-v1.3T fixed)

Details

(Whiteboard: [tarako-bug-bash-1.3T][POVB][sprd292039])

Attachments

(1 attachment)

Posted file logcat_with_ril
Build Information
Gaia      f0872318d46781bb59d0a13a2e1fffb115b8ca2b
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/9ff031daa73c

Device: Tarako
Build ID: 20140417152301

Platform Version: 28.1

Description



Steps to Reproduce

0. Connect a headset contains mic
1. Launch Dialer
2. Make a phone call to another device
3. Pick up the phone
4. Speak something from headset -> Verify MO can hear complete sentence

Expected Results
Can hear complete sentence 

Actual Results
Only can hear 1~2 seconds

Other Notes

Reproduction Frequency: 100%
Component: Gaia → Gaia::Dialer
blocking-b2g: --- → 1.3T?
Hi Sam:
 Could you please help check this issue first?

Audio channel/driver issue?


04-18 08:45:30.010 E/audio_hw_primary(   88): Entering IN_CALL state, is first call...devices:0x1 mode:2
04-18 08:45:30.010 V/AudioPolicyManagerBase(   88): setPhoneState() state 2
04-18 08:45:33.240 W/audio_hw_primary(   88): SetCall_ModePara successfully, device: earpice(Close), headphone(Open), speaker(Close), Mic(Close), hp_mic(Open) devices(0x100004)
04-18 08:47:50.190 E/audio_hw_primary(   88): Leaving IN_CALL state, call_start=0, mode=0 devices:0x4
04-18 08:47:50.190 V/AudioPolicyManagerBase(   88): setPhoneState() state 0
Flags: needinfo?(sam.hua)
blocking-b2g: 1.3T? → 1.3T+
Hi! James,

Any progress?

--
Keven
Flags: needinfo?(james.zhang)
This should be vendcom issue, not dialer one.
Component: Gaia::Dialer → Vendcom
Whiteboard: [tarako-bug-bash-1.3T] → [tarako-bug-bash-1.3T][
Whiteboard: [tarako-bug-bash-1.3T][ → [tarako-bug-bash-1.3T]
Whiteboard: [tarako-bug-bash-1.3T] → [tarako-bug-bash-1.3T][POVB]
Assignee: nobody → sam.hua
Hi Thomas,
it can't be reproduced in our test team. u can contact Ting.chen@spreadtrum.com (ext 2321).
Flags: needinfo?(sam.hua) → needinfo?(ttsai)
Do you need update modem and nvitem?
Flags: needinfo?(james.zhang)
verify again with 0417 pac + pvt v1.3t build, still has this problem
Gaia      9aa9b04049f0291b124c50e0f9c3ce0e1f547725
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/2e40920b1d13
BuildID   20140422164001
Version   28.1
We can't reproduce this bug on my side with 4.22 and 4.23 hudson build.
Can you test another handset or phone, maybe it's specific hardware issue.
Whiteboard: [tarako-bug-bash-1.3T][POVB] → [tarako-bug-bash-1.3T][POVB][sprd can't reproduce]
Flags: needinfo?(mlien)
verify with two devices and two headsets by different combinations, still has this problem
Gaia      8895b180ed636069473703d0e7b73086989601ce
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/7caf4b5abfce
BuildID   20140428014001
Version   28.1
Flags: needinfo?(mlien)
Talked with Thomas, I think PVT build need update kernel. And use latest release pac to update modem and nv.
(In reply to James Zhang from comment #9)
> Talked with Thomas, I think PVT build need update kernel. And use latest
> release pac to update modem and nv.

The devices from comment 8 already used the latest (0418) pac file
We are unable to reproduce this issue on latest pvt with 0418 pac file. 

Test build:
Gaia      f48eb064b786652528af1c8fa6a4784695732bc9
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/bc5f0e461c9e
BuildID   20140429164003
Version   28.1
ro.build.version.incremental=eng.cltbld.20140429.202101
ro.build.date=Tue Apr 29 20:21:11 EDT 2014
William, pls help Mike to check why pcheng can't reproduce this issue.
Flags: needinfo?(whsu)
OOP~ It might related to headset.

I can reproduce it while I used bluetooth headset to reproduce this bug.
But, I cannot reproduce it via wired headset.

* Build Information: (Base image: 4/18)
 - Gaia      b5adc5a943d3abbd6ab070a47c847f2c24891cc5
 - Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/e9890f5d4709
 - BuildID   20140429014002
 - Version   28.1

* Bluetooth device:
 - Jabra wave+

* Reproduce step:
 1. Pair a bluetooth headset
 2. Make a phone call
 3. Say something while in call.

* Actuall result:
 - Cannot hear any voice
Flags: needinfo?(whsu)
Hi, Mike,

Could you please provide the headset model you used?
Thanks!
(In reply to William Hsu [:whsu] from comment #14)
> Hi, Mike,
> 
> Could you please provide the headset model you used?
> Thanks!

I test two headsets, one is buri's headset and another is iphone's headset
verify again with today's daily build, it still has this problem
I cannot hear the whole sentence speaking from headset

Gaia      1177a857a3caeb8fd1feae94c83298a9144c2ff5
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/d28bb1e73b91
BuildID   20140504014000
Version   28.1

confirm with William's test devices
two Bluetooth headsets are fine: Jabra wave+ and Sony MW600
two wired headsets have problem: iPhone and Alcatel headsets

we suspect this is due to headset compatible problem, we will try other wired headsets
Whiteboard: [tarako-bug-bash-1.3T][POVB][sprd can't reproduce] → [tarako-bug-bash-1.3T][POVB][sprd292039]
Fixed on my side. The audio owner use Chinese description...You can use google translate if you're confuse.

device/sprd
commit 3baa575b6e6ab82a233150455b052bf29c0ccbd7
Author: Zuo.Wang <zuo.wang@spreadtrum.com>
Date:   Wed May 7 13:49:19 2014 +0800

    Bug#292039 - 连接蓝牙耳机接入来电,在关闭蓝牙耳机后再接听,对方听不到声音 
    [self test ] pass
    
    Change-Id: If236e1aa7f93bff7f7a406eb234c10ff2b6be191
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Flags: needinfo?(ttsai)
Maybe we need the new PAC file to do the test again before release.
You need to log in before you can comment on or make changes to this bug.