Closed Bug 998152 Opened 6 years ago Closed 6 years ago

[Tarako] going to browser settings and then going back can show a "This is embarassing" page

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 991547
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: nhirata, Assigned: daleharvey)

Details

(Whiteboard: [tarako-bug-bash-1.3T])

1. reboot device
2. launch browser
3. open tab
4. go to settings
5. hit done
6. hit back

Expected: top 4 web pages. (all 4 are text only web pages)
Actual: "This is embarassing"; reload and close tab buttons do not do anything

Gaia      a8d2d399f2939f4845abaa0df57abab241a2c782
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/d97dad54cb61
BuildID   20140417004002
Version   28.1
ro.build.version.incremental=eng.cltbld.20140417.115200
ro.build.date=Thu Apr 17 11:52:06 EDT 2014
Tarako
blocking-b2g: --- → 1.3T?
ni? Naoki, can the user recover this easily by refreshing the page?
it seems like this will happen on any device if the page itself is high-memory-consuming 
Thanks
Hi Joe, this doesn't happen on buri.  It's just a simple going to the settings and then coming back.  I can't recall how the images of the webpages are displayed.  We may need some input from either Dale Harvey or Ben Francis.  Having said that I don't think we should be showing this page when the user hasn't even invoked a web page directly.
Do we start a new process for the settings?
Flags: needinfo?(dale)
We open an activity which is gonna start a new process

I think all of these bugs come under the general fix of 'assume background tabs can crash and reload when they come into the foreground' instead of the current behaviour of displaying them to the user (foreground tabs crashing will still be shown to the user)

https://bugzilla.mozilla.org/show_bug.cgi?id=998118
https://bugzilla.mozilla.org/show_bug.cgi?id=991547

are pretty much the same, should get a PR up for it tonight
Flags: needinfo?(dale)
Yeah not much we can do here. Either share the process or we can always come up with an example where the page gets killed.
Sorry got a little confused by the steps to reproduce, I assumed it means go to the settings app (via the offline error page)

We dont spin a new process for the in browser settings, however on a low memory device pretty much any activitey can oom a background tab (we setvisible(false) if its not in the foreground).

The fix for https://bugzilla.mozilla.org/show_bug.cgi?id=991547 also applied here
Assignee: nobody → dale
hi Dale, should we dup this bug to bug 991547? thanks
Flags: needinfo?(dale)
As the other one has landed, yup
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(dale)
Resolution: --- → DUPLICATE
Duplicate of bug: 991547
blocking-b2g: 1.3T? → ---
You need to log in before you can comment on or make changes to this bug.