Closed Bug 998161 Opened 8 years ago Closed 8 years ago

[Tarako] email hang with large amount of emails

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: guigs, Unassigned)

Details

(Whiteboard: [tarako-bug-bash-1.3T])

Build Information 20140417152301

Device: Tarako
Build ID: 
Platform Version: 28.1

Description: When setting up a gmail account on the app with more that 3 gb of data in the inbox, the loading messages hangs. After restarting the device and relaunching the app the homescreen is the set up account for a second then goes back to the inbox. Relaunching again a few emails load. However it is sporadic. 

Steps to Reproduce

1. Reset phone. 
2. Launch email app
3. set up a gmail account with more than 2.5 GB
4. let the email inbox load

Expected Results
for the first few messages to show up

Actual Results
hangs at the inbox screen with no messages. 


Other Notes
After relaunching the app the setup screenshows up and then goes straight to the inbox without inputting anything. 
Reproduction Frequency:
Component: Gaia → Gaia::E-Mail
IMAP message sync is time-based and does not care about the size of your folders, just the message density.  Tarako has limited memory so this is much more likely to be a serious problem for it.  Can you clarify "hang"?  I expect we'd just run out of memory and crash and that would be the end of the story for us, so a hang is surprising.  Providing a logcat per https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo will help us better understand what is happening.

Bug 823384 for partial day sync is the likely bug to dupe to if we're OOM'ing, although other Tarako bugs relating to memory usage may also be relevant.
I can loan a tarako device to Rachel to allow her to reproduce this again so that we can get a logcat with the required email logs.

Rachel - Can you help answer comment 1?
Flags: needinfo?(rmcguigan)
I worked with Rachel to try to diagnose this, but we were unable to reproduce this with multiple attempts.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(rmcguigan)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.