Closed Bug 998267 Opened 8 years ago Closed 7 years ago

[e10s] opening a new remote tab shows the loading throbber

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 35
Iteration:
35.2
Tracking Status
e10s + ---

People

(Reporter: ttaubert, Assigned: ttaubert)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Opening a new tab shouldn't show the page load throbber.
With the current privileged newtab page we could have just removed the gMultiProcessBrowser check but this patch actually works with new remote tabs, e.g. when setting browser.newtab.url=about:home.
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Attachment #8494963 - Flags: review?(wmccloskey)
Component: General → Tabbed Browser
Comment on attachment 8494963 [details] [diff] [review]
0001-Bug-998267-Don-t-always-show-the-throbber-when-openi.patch

Review of attachment 8494963 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Tim.
Attachment #8494963 - Flags: review?(wmccloskey) → review+
Iteration: --- → 35.2
Points: --- → 2
Flags: firefox-backlog+
QA Whiteboard: [qa+]
Flags: qe-verify+
QA Contact: alexandra.lucinet
QA Whiteboard: [qa+]
https://hg.mozilla.org/mozilla-central/rev/51f1360f4e85
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
Reproduced with Nightly 2014-09-24 on Windows 7 64-bit - with e10s enabled, the throbber is displayed when a New Tab is opened.
Verified as fixed with latest Nightly 35.0a1 (Build ID: 20140926030202) on: Mac OS X 10.9.4, Ubuntu 14.04 64-bit and Windows 7 64-bit.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.