Closed Bug 998300 Opened 6 years ago Closed 6 years ago

Intermittent browser_net_copy_image_as_data_uri.js | Test timed out | Found a tab after previous test timed out: http://example.com/browser/browser/devtools/netmonitor/test/html_content-type-without-cache-test-page.html

Categories

(DevTools :: Netmonitor, defect)

26 Branch
x86_64
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 872379

People

(Reporter: RyanVM, Unassigned)

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=38079805&tree=Fx-Team

Rev5 MacOSX Mountain Lion 10.8 fx-team opt test mochitest-devtools-chrome on 2014-04-18 02:27:32 PDT for push 6d1315e1a026
slave: talos-mtnlion-r5-030

02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 31/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 32/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 33/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 34/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 35/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 36/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 37/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | Console message: 1397813868337	Browser.Experiments.Experiments	ERROR	Experiments #0::httpGetRequest::onLoad() - Request to http://127.0.0.1:8888/experiments-dummy/manifest returned status 404
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 38/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 39/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | Console message: 1397813868350	Browser.Experiments.Experiments	ERROR	Experiments #0::_loadManifest - failure to fetch/parse manifest (continuing anyway): Error: Experiments - XHR status for http://127.0.0.1:8888/experiments-dummy/manifest is 404
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | Console message: 1397813868350	Browser.Experiments.Experiments	TRACE	Experiments #0::_evaluateExperiments
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | Console message: 1397813868352	Browser.Experiments.Experiments	TRACE	Experiments #0::_main finished, scheduling next run
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 40/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 41/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 42/78, 0/0
02:37:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | > Network events progress: 43/78, 0/0
02:37:51     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | Console message: [JavaScript Error: "A promise chain failed to handle a rejection.
02:37:51     INFO -  Date: Fri Apr 18 2014 02:37:47 GMT-0700 (PDT)
02:37:51     INFO -  Full Message: TypeError: this.docShell is null" {file: "chrome://global/content/bindings/browser.xml" line: 310 column: 0 source: "310"}]
02:38:32     INFO -  libpng warning: zero length keyword
02:38:32     INFO -  libpng warning: Empty language field in iTXt chunk
02:38:33     INFO -  TEST-INFO | screencapture: exit 0
02:38:33  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | Test timed out
02:38:33     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | finish() was called, cleaning up...
02:38:33     INFO -  TEST-INFO | MEMORY STAT vsize after test: 4057292800
02:38:33     INFO -  TEST-INFO | MEMORY STAT residentFast after test: 952332288
02:38:33     INFO -  TEST-INFO | MEMORY STAT heapAllocated after test: 158821168
02:38:33     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | finished in 45037ms
02:38:33  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_copy_image_as_data_uri.js | Found a tab after previous test timed out: http://example.com/browser/browser/devtools/netmonitor/test/html_content-type-without-cache-test-page.html
Has not occurred since fix for bug 872379 landed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 872379
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.