[B2G][Tarako][Homescreen]Intermittent animation disturbance when user closes App after tapping Homescreen button on device

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: mclemmons, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected, b2g-v1.3T affected)

Details

(Whiteboard: [tarako-exploratory], )

Attachments

(2 attachments)

User taps App (either in Dock or Homescreen), allows it to open, and then closes shortly thereafter (less than 5 seconds after open) by tapping the Homescreen button on device. Three scenarios occur: 1) App animation at closure vanishes comfortably without much recognition to the user 2) The App closing will present a hiccup effect with the App icon double flashing before closure 3) The App closes but flashes briefly as the animation vanishes recognizably. The inconsistency in these device reactions are concerning.

Repro Steps:
1) Updated Tarako to BuildID: 20140418014001
2) Tap any App and allow it to open completely
3) Tap the Homescreen button shortly after opening App


Actual:
One of three results: 
1) App animation at closure vanishes comfortably without much recognition to the user 
2) The App closing will present a hiccup effect with the App icon double flashing before closure 
3) The App closes but flashes briefly as the animation vanishes recognizably. 

Expected:
App animation at closure vanishes consistently and comfortably without much recognition to an observant user.

Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140418014001
Gaia: f0872318d46781bb59d0a13a2e1fffb115b8ca2b
Gecko: 32bb713e6d0d
Version: 28.1
Firmware Version: sp6821

Notes:
Repro frequency: (30/100, 30%)
See attached: (video clip, logcat)
In addition to comment 0, you may fast forward to the 12 second mark of the video to visualize the "hiccup effect" with the App closure animation.
This issue reproduces on Buri 1.3 intermittently. Following the STR in Comment 0 demonstrates intermittent behavior of 1) App animation at closure vanishes comfortably without much recognition to the user 2) The App closing will present a hiccup effect with the App icon double flashing before closure 3) The App closes but flashes briefly as the animation vanishes recognizably. 

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140418024004
Gaia: 4aae5c8e9ac9a3d7ea7e83172dda6e11169cd677
Gecko: 0fd9f6fe8832
Version: 28.0
Firmware: v1.2-device.cfg
Component: Gaia::Homescreen → Gaia::System::Window Mgmt
Closing all intermittent test failures for Firefox OS (since we're not focusing on it anymore).

Please reopen if my search included your bug by mistake.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.