Closed Bug 998424 Opened 6 years ago Closed 6 years ago

[Tarako] Not displaying thumbnail of relatively large image 15.8 MB jpg

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3T affected)

RESOLVED INVALID
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: nick, Unassigned)

References

Details

(Whiteboard: [tarako-bug-bash-1.3T])

Build Information

Device: Tarako
Build ID: 
Platform Version: 28.1

Description
Not displaying thumbnail of relatively large image 15.8 MB jpg


Steps to Reproduce

1. 
2. 
3. 

Expected Results


Actual Results


Other Notes

Reproduction Frequency:
djf, sorry to bother you; I can't recall if this is intentional or not for a large image?
Flags: needinfo?(dflanagan)
This is intentional. If you look in the logcat there is probably a message saying that the large image was being skipped because it was too large. Until the recent introduction of #-moz-samplesize, we couldn't even open a large image like that without OOM.  This bug is not specific to 1.3T. No version of the gallery app, on any device, would be able to open a 15mb jpeg file.  I can't even imagine how huge that is.

I'm going to close this as invalid.

Nick: feel free to file a bug like "[Gallery]: Support large JPEG images".  Eventually (possibly in the 2.0 timeframe) we will want to start using the new #-moz-samplesize media fragment to allow us to open small size versions of large images.  In theory we ought to be able to preview huge images like yours.  But that is not a fix that is going to get into 1.3T or 1.4.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(dflanagan) → needinfo?(nick)
Resolution: --- → INVALID
See Also: → 1001712
Flags: needinfo?(nick)
You need to log in before you can comment on or make changes to this bug.