[PP] Some GIFs don't load - shown as black box with noise at bottom

VERIFIED FIXED in M10

Status

()

Core
ImageLib
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: adb, Assigned: pnunn)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Overview Description:

On the Mozillazine "Chrome Gallery" page the first and last thumbnails
(mozillazine and default) load correctly.  The middle three (simple, kids,
minimalist) load as black boxes.  A screenshot of what it looks like on my
machine is at http://www.tardis.ed.ac.uk/~adb/moz1.gif

Steps to Reproduce:
1) Go to http://www.mozillazine.org/chrome/gallery.html
2) Note how it appears to hang for a few seconds while loading images.
3) Hopefully, it should look like the screenshot at
http://www.tardis.ed.ac.uk/~adb/moz1.gif

Actual Results:
Middle three thumbnails appear as black boxes, occasionally with noisy bits
(random blue pixel, or ragged white pixels on last line).

Expected Results:
GIFs should be displayed properly.  Communicator 4.61 loads the images
correctly.

Build Date & Platform Bug Found:
16 July 1999 Win32 nightly build (Running on WinNT 4.0 SP4)

Additional Builds and Platforms Tested On:
This bug *does not* occur on the 16 July 1999 Linux nightly build.

Additional Information:
If you load just the image URL (such as
http://www.mozillazine.org/chrome/image/simple-thumb.gif) then the bug still
occurs.  HOWEVER, if you save the GIF to your local disk (using wget) then use
Mozilla to load it from the file then it displays correctly.  Hmm, maybe it's a
problem in the network code?

Comment 1

19 years ago
First, adb@tardis.ed.ac.uk, thank you for the most comprehensive and clear
imaging bug report I have ever seen reported on Bugzilla! Much appreciated!

That said, I can't reproduce it using the 7.16.99 nightly build. We've had other
networking-related bugs with similar symptoms, from Mozilla folks using dial-up
connections.

So, I'd like to suggest holding onto this bug until after Necko lands, unless
pnunn has an alternative preference.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
Waiting For Necko. (WFN)
-pn

Comment 3

19 years ago
The same bug is witnessed at http://people.netscape.com/bienvenu/, with the
1999072408 MICROSOFT WINDOWS 98 Apprunner build.
Query - might there not be a "Win32" option in the OS list, *should* it be
determined that all the wondrous flavors of that genus are infested?
(Assignee)

Updated

19 years ago
Target Milestone: M10
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 4

19 years ago
Works for me. This behavior may have been
the result of one of the earlier layout/repaint
bugs.
-pn

Comment 5

19 years ago
[Pinged originator and crysgem. I never was able to reproduce this bug, and don't
want to erroneously stamp it as verified if it's still present.]

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Per Andrew Birkett (bug reporter), this bug cannot be reproduced any longer, and
appears to be fixed. Thus, marking as verified.

Thanks again, Andrew!

Updated

19 years ago
Status: VERIFIED → REOPENED

Comment 7

19 years ago
Comrades, I must ReOpen this report to attention. Access
http://people.netscape.com/bienvenu/ - as I did, with the 1999091010 Apprunner
agent, upon MICROSOFT WINDOWS 98 - the very flaw described is hideously
illustrated.

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 8

19 years ago
Clearing WORKSFORME resolution due to reopen.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

19 years ago
arrrgh.
Don't mix apples and oranges.
Open a new bug for the new location if you have a problem
with a different gif. It is probably a different problem.
I'm closing this one.
-pn

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.