Closed Bug 998851 Opened 6 years ago Closed 6 years ago

[tarako][wifi] wifi got error after monkey test

Categories

(Firefox OS Graveyard :: Wifi, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(blocking-b2g:1.3T+, firefox29 wontfix, firefox30 wontfix, firefox31 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S1 (9may)
blocking-b2g 1.3T+
Tracking Status
firefox29 --- wontfix
firefox30 --- wontfix
firefox31 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: seinlin, Assigned: seinlin)

References

Details

Attachments

(1 file)

04-18 21:24:03.090   611   638 W WifiHW  : wifi_command: DRIVER SCAN-PASSIVE
04-18 21:24:03.090   611   638 W WifiHW  : command is rejected! supplicant is terminating
04-18 21:24:03.090   611   611 E GeckoConsole: [JavaScript Error: "this is undefined" {file: "jar:file:///system/b2g/omni.ja!/components/WifiWorker.js" line: 2493}]
Attachment #8409527 - Flags: review?(vchang)
blocking-b2g: --- → 1.3T?
Comment on attachment 8409527 [details] [diff] [review]
Bind this to callback function

Review of attachment 8409527 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Thank you.
Attachment #8409527 - Flags: review?(vchang) → review+
triage: we will take this for 1.3T to improve wifi stability
blocking-b2g: 1.3T? → 1.3T+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/b7d2b4c6a5b0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S1 (9may)
Should this land on 1.4 too?
status-b2g-v1.4: --- → ?
Flags: needinfo?(kli)
Flags: needinfo?(kli)
Yes, it should also land on 1.4. Thanks!
Sorry to be a hassle, but you need to request aurora approval on the patch then. 1.3T+ doesn't grant auto-approval to patches for 1.4 :)
Blocks: dolphin
Comment on attachment 8409527 [details] [diff] [review]
Bind this to callback function

[Approval Request Comment]
Bug caused by (feature/regressing bug #): scanning error in WiFi driver
User impact if declined: WiFi worker thread will get error when there is something wrong in scanning
Testing completed (on m-c, etc.): Monkey test on v1.3t
Risk to taking this patch (and alternatives if risky): low because it is a syntax change to make it work correctly
String or IDL/UUID changes made by this patch: none
Attachment #8409527 - Flags: approval-mozilla-aurora?
Comment on attachment 8409527 [details] [diff] [review]
Bind this to callback function

low risk change, approving on aurora.
Attachment #8409527 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: checkin-needed
Comment 9 was when B2G v1.4 was still on Aurora. I'm assuming the approval was intended for b2g30_v1_4 where it has been for the past 2 weeks now.
Keywords: checkin-needed
Whiteboard: [checkin-needed-b2g30]
You need to log in before you can comment on or make changes to this bug.