'Taking webcam photos' example given in JSFiddle site doesn't capture image in Firefox.

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: mayanktg, Assigned: sheppy)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.117 Safari/537.36

Steps to reproduce:

* Open the link http://jsfiddle.net/codepo8/agaRe/4/ (JSFiddle example) given in the page https://developer.mozilla.org/en-US/docs/WebRTC/Taking_webcam_photos using Firefox.
* Click the 'Take photo' button given in the example.



Actual results:

When using Firefox, the captured image isn't displayed in the preview area.


Expected results:

The captured image from the cam should have been displayed in the preview pane instead of the default placeholder.
(Reporter)

Updated

5 years ago
OS: All → Linux
Hardware: All → x86_64

Updated

5 years ago
Assignee: eshepherd → nobody
Component: API: WebRTC → WebRTC
Product: Developer Documentation → Core

Updated

5 years ago
Assignee: nobody → eshepherd
Status: UNCONFIRMED → NEW
Component: WebRTC → API: WebRTC
Ever confirmed: true
OS: Linux → All
Product: Core → Developer Documentation
Hardware: x86_64 → All

Comment 1

5 years ago
Confirmed on OSX with FX 31.
For me with FF 30 on OSX it works as expected as you can see in the attached screen shot.
Which Firefox version was used in the original tests?
Flags: needinfo?(mayanktg)
(Reporter)

Comment 3

5 years ago
(In reply to Nils Ohlmeier [:drno] from comment #2)
> Created attachment 8429361 [details]
> Screnshot of the working result
> 
> For me with FF 30 on OSX it works as expected as you can see in the attached
> screen shot.
> Which Firefox version was used in the original tests?

The tested it on Ubuntu 12.04 (64 Bit) with FF 29.0.1 and aleth confirmed it on OSX with FF 31.
Flags: needinfo?(mayanktg)
Hardware: All → x86_64
Did some more testing on this:

It turns out that with empty profile this is indeed broken on all version from 29.0.1 to 32 for me.
But if I use my standard user profile (with certain add-ons etc) it works fine for me.
The example is there now: http://mdn-samples.mozilla.org/s/webrtc-capturestill/ (linked from the page) and is working.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.