Closed Bug 999017 Opened 6 years ago Closed 5 years ago

[B2G][Tarako][Clock]Adding alarm demonstrates user interface transition problem when created on device

Categories

(Firefox OS Graveyard :: Gaia::Clock, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 affected, b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 1118343
Tracking Status
b2g-v1.3 --- affected
b2g-v1.3T --- affected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 files)

Attached file Firewatch data
User taps Clock App, taps the add new alarm icon and inputs an alarm name. When user completes, the transition screen afterward shows the bottom half of the page slowly transitioning with the clock and the newly created alarm. It is not a smooth transition and looks awkward while it is transitioning as a black area displays then changes to the expected alarm name content.

Repro Steps:
1) Updated Tarako to BuildID: 20140421014001
2) Tap Clock App and tap alarm icon
3) Input a name for the alarm and tap done

Actual:
The home page with the clock and newly created alarm transitions slowly and resembles a black space area where the keyboard once appeared. Within two seconds, the alarm name appears where the black area appeared but this presents an undesirable user interface experience.

Expected:
The home page with the clock and newly created alarm transitions comfortably without black space or an undesirable user interface experience.

Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140421014001
Gaia: 68e072af2348c46fbff8a35d99ff10caeab16880
Gecko: a8cc1aaec6a3
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac

Notes:
Repro frequency: (9/10, 90%)
See attached: (firewatch, video clip = https://www.youtube.com/watch?v=DJ597gokzyM, logcat)
This issue does reproduce on 1.3 Buri. Following the STR from Comment 0, user witnesses the transitioning between the alarm creation screen and the return to the clock screen with the alarm name presented demonstrating a slow pace. White area displays briefly where the pop up keyboard appeared before the alarm name content appears. This is the slight difference between the Buri 1.3 and Tarako 1.3T. But unexpected behavior is consistent. 

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140421024003
Gaia: 69dcf31d3a95765a7d7c54a14acf6adca23f351d
Gecko: b43a6c8e467d
Version: 28.0
Firmware version: v1.2-device.cfg
Attached file Clock Alarm Logcat.txt
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118343
You need to log in before you can comment on or make changes to this bug.