Closed Bug 999083 Opened 7 years ago Closed 6 years ago

Fulah Characters missing on Firefox OS

Categories

(Firefox OS Graveyard :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1126641

People

(Reporter: arky, Assigned: padamczyk)

References

Details

Attachments

(2 files)

Some of the Fulah characters "ɗ ƴ ŋ ɓ" are missing on Firefox OS. 

"When written using the Latin script, Fula uses the following additional special "hooked" characters to distinguish meaningfully different sounds in the language: Ɓ/ɓ [ɓ], Ɗ/ɗ [ɗ ], Ŋ/ŋ [ŋ], Ñ/ñ [ ɲ], Ƴ/ƴ [ʔʲ]. The apostrophe (ʼ) is used as a glottal stop. In Nigeria ʼy substitutes ƴ, and in Senegal ñ is used instead of ɲ.[clarification needed]

Sample Fula alphabet

a, aa, b, mb, ɓ, c, d, nd, ɗ, e, ee, f, g, ng, h, i, ii, j, nj, k, l, m, n, ŋ, ny (or ñ or ɲ), o, oo, p, r, s, t, u, uu, w, y, ƴ

The letters q, x, z are used in some cases for loan words. In the Pular of Guinea an additional letter, ɠ, is also part of the orthography."

Source: http://en.wikipedia.org/wiki/Fula_language
Patryk: some more Latin characters we'll need in Fira, to support additional languages. (Really, we should aim for complete Unicode extended-Latin support, though that'll be quite a bit more work.)
I have tested the latest Geeksphone master build. Some of the Fulah characters are available. 

Ibrahima, Can you please confirm if all the character are supported on master builds. Thanks
Flags: needinfo?(ibrahima.sarr)
All the characters appear on my Keon but some bold characters look like font substitutes. The font used as Default in Firefox OS does not seem to have them.
Anyway any font that does not support full Extended Latin support will cause problems.
We also have that problem with all Mozilla fonts including those used for the Web.
Flags: needinfo?(ibrahima.sarr)
Right - if the characters aren't present in Fira, then font fallback will find them in some other font such as Roboto, and they won't match stylistically (especially when we're using some of the extra weights of Fira such as Light, where no matching weight is available in the fallback). This isn't an acceptable user experience; we need full support in our default (Fira) fonts, for a clean and consistent appearance.
+1 Jonathan, I fully agree.
We have that issue to with Open Sans. If Mozilla wants to be global, this needs to be adressed.
Attached image Screenshot
Hi guys,

Looks like there are still some missing glyphs in Fira for Fulah (see attached screenshot taken by Ibrahima). What are the next steps here?
Jonathan, Know any meta bugs to track the development of Fira fonts? We need to add this bug (and few others) that depends on complete unicode character support in Fira. Thanks!
Flags: needinfo?(jfkthame)
You could file an issue at https://github.com/mozilla/Fira/issues, specifying exactly what needs to be added. Patryk, is this on your radar? Anything else we should do to ensure this is addressed?
Flags: needinfo?(jfkthame) → needinfo?(padamczyk)
:arky, please needsinfo me on any future Fira bugs. Since Fira updates are aligned with Firefox OS releases we will likely address this in the next release of the OS: v.2.2.
Assignee: nobody → padamczyk
Flags: needinfo?(padamczyk)
Depends on: 1126641
Fulah is a big candidate for 2.0 launches in Africa. Can we get an ETA on this please?
thanks!
[Blocking Requested - why for this release]:

Fulah committed to on 2.0. Nominating
Flagging :bajaj so this comes in her pipeline :) thanks!
Patryk: is there anything else here we need to get this moving forwards? Thanks!
blocking-b2g: --- → 2.0?
Flags: needinfo?(padamczyk)
Flags: needinfo?(bbajaj)
The updated font in bug 1126641 should have the fulah characters, so we need to get that integrated into the builds. There will be another update with more characters for the African continent in about 2 weeks.
Flags: needinfo?(padamczyk)
Status: NEW → RESOLVED
blocking-b2g: 2.0? → ---
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1126641
(In reply to Patryk Adamczyk [:patryk] UX from comment #12)
> The updated font in bug 1126641 should have the fulah characters, so we need
> to get that integrated into the builds. There will be another update with
> more characters for the African continent in about 2 weeks.

clearing the NI here as the DUP is blocking.
Flags: needinfo?(bbajaj)
You need to log in before you can comment on or make changes to this bug.