pages fail to load fully with WWWOFFLE (reload)

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
18 years ago
7 years ago

People

(Reporter: Marko.Macek, Unassigned)

Tracking

({qawanted})

Trunk
x86
Linux
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
With 0.9.4 I am having problems when using the WWWOFFLE Offline Cache (on linux).

When I try to load a new page from the URL (or do shift+reload), I only get a
partial page loaded. 

If I just reload (from cache), I get the entire page from the WWWOFFLE cache.

Things are fine in 0.9.3.
-> darin

darin, see bug 86327, which eventually ends up at a bug you marked fixed. Not
sure if its related, though
Assignee: neeti → darin

Comment 2

18 years ago
if you are offline how can you possibly expect to be able to fetch a new page?
(Reporter)

Comment 3

18 years ago
I guess I was not clear enough. I have these problems when online. No problems
when offline and working from cache only.

I also have mozilla set to HTTP/1.0 and it makes no difference.

Comment 4

18 years ago
ok.. makes sense... is there a link where i can get a copy of WWWOFFLE?  is it
free software?

Comment 6

17 years ago
WWWOffle is a proxy that can be switched offline. It then delivers cached pages
or error messages, nothing to do with Mozilla's cache or offline mode.

I have the same problem, only with Mozilla (0.9.4, tried NS4) and only with
wwwoffle (2.5 and 2.6d, tried squid). If you hit reload a few times every page
loads.

Observation: It seems to me that all affected pages had complicated layouts and
a lot of JS in their header.

Comment 7

17 years ago
-> future

need help setting up a testcase, or... reporter can you please generate a http
log of your session?

see: 
http://lxr.mozilla.org/seamonkey/source/netwerk/protocol/http/src/nsHttp.h#36
Keywords: qawanted
Target Milestone: --- → Future
(Reporter)

Comment 8

17 years ago
Created attachment 55449 [details]
http log when WWWOFFLE is in online mode
(Reporter)

Comment 9

17 years ago
Created attachment 55450 [details]
http log when WWWOFFLE is in offline mode
(Reporter)

Comment 10

17 years ago
I attached two logs. the "offline" one is the one where everything is fine. When
"online" the page is truncated.

The URL used is "http://www.atlasf1.com/bb/index.php". But the problem shows
itself on other pages too, including http://freshmeat.net.

I had HTTP Version set to 1.0 with keep-alive and pipelining disabled.

Comment 11

17 years ago
Created attachment 55454 [details]
Failure and success with HTTP 1.1, keepalive, no pipelining

Comment 12

17 years ago
To get a log I additionally had to use the modules sync and bufsize, otherwise
Mozilla would leave the file empty: export NSPR_LOG_MODULES="nshttp:5, sync:1,
bufsize:0"

get mozilla start page
get http://www.webwriting-magazin.de/webwriting/stangl.shtml
get and post to switch wwwoffle offline
get stangl.shtml again just see wwwoffle's error message "client closed the
connection while online => nothing cached"

Of 10 attempts over two days pages on that site never fully loaded. Google works
most of the time, but when it doesn't all that helps is "no proxy". Everything
else is usually ok, at least after one Alt-R.

Comment 13

17 years ago
I'm "not authorized to edit attachements". Well, then somebody else might want
to correct the mime type from octet-stream to x-gzip :-)
(Reporter)

Updated

17 years ago
Attachment #55454 - Attachment mime type: application/octet-stream → application/x-gzip

Comment 14

17 years ago
*** Bug 128579 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
*** Bug 109056 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
some info from bug 109056

this bug occurs in 2.6d but not for 2.7beta for me.
(for the reporter it occurs 2.6d and 2.7 seems to be totally broken for him)

after testing, it seems the configuration option
reply-compressed-data = yes
fixes the problem although it's not clear whether it's a bug in the proxy or
mozilla ... (most likely proxy)

Updated

16 years ago
Blocks: 163294

Comment 17

16 years ago
*** Bug 197892 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
the wwwoffle option "reply-compressed-data = yes" reduces the troubles 
(but there are even problems with google; for using google here only filtering
out javascript helps)
as mentioned in Bug 197892 this happens now with css, too
I have not had this problems with earlier versions of mozilla (I guess it was
before mozilla 1.3)
using the debug of wwwoffle shows a connection, close and reconnection for the
same address by mozilla (imho this explains why the page is only loaded partially)
using other browsers everything works fine

Updated

13 years ago
Assignee: darin → nobody
QA Contact: benc → networking
Target Milestone: Future → ---

Comment 19

12 years ago
Is this still a problem?  Last comment is about four years old.

Comment 20

12 years ago
I suppose Mozilla is still broken but nobody uses wwwoffle anymore...
Please reopen if this still happens
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.